Wife can't send me iMessage by my phone number, I can to her number?

Discussion in 'iOS 5 and earlier' started by RollTide1017, Oct 13, 2011.

  1. RollTide1017 macrumors regular

    Joined:
    Sep 28, 2009
    Location:
    Montgomery, AL
    #1
    Anyone else having strange issues with iMessage?

    My wife cannot send me an iMessage using my phone # but, she can using my email. I can send her an iMessage using either her phone number or her email. She is on an iPhone 4 and I'm on a 3GS ('til tomorrow). Why dosen't my phone number register as an iMessage device for her. I've checked our Message settings on both phones and they are the same; both our emails and phone #'s are listed under "receive at" addresses, both our caller ID's are set to each other's phone number.

    I can't figure it out; no matter what address I use for her, it goes through as an iMessage but, it only works for her if she uses my email. Need to figure this out since most people with iPhones will be using my phone number to text me.
     
  2. chrismac2 macrumors regular

    chrismac2

    Joined:
    Jan 14, 2008
    Location:
    Renton, WA
    #2
    Hmmmm, that is an odd one. Not sure, but maybe it hasn't really "activated" iMessage for you phone number.

    Maybe you should try turning iMessage off and back on again, and see if it reactivates?
     
  3. RollTide1017 thread starter macrumors regular

    Joined:
    Sep 28, 2009
    Location:
    Montgomery, AL
    #3
    Yea, it's weird and driving mean crazy trying to figure it out. I've tried turning iMessage on and then off again and nothing changes. Oh well, my 4S should be here tomorrow so maybe that will fix the issue.
     
  4. luke.mac1 macrumors member

    Joined:
    Jun 1, 2011
    Location:
    United Kingdom
  5. carlessd macrumors newbie

    Joined:
    Oct 16, 2011
    #5
    iMessage

    you can't i message to numbers, you have to use there email address:)
     
  6. MacBoy88 macrumors regular

    Joined:
    Feb 4, 2003
    Location:
    Illinois
    #6
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Make sure your phone number is or matted correctly in her contacts.

    Have you tried to manually type in your number?
     
  7. HE15MAN macrumors 6502a

    HE15MAN

    Joined:
    Sep 3, 2009
    Location:
    Florida's Treasure Coast
    #7
    This is the problem. Add her itunes email address to her contact info and it will work
     
  8. MooneyFlyer macrumors 65816

    MooneyFlyer

    Joined:
    Nov 18, 2007
    Location:
    Boston
    #8
    Where did you find that? I don't think it is true... as a matter of fact, I'm nearly certain that it isn't.
     
  9. luke.mac1 macrumors member

    Joined:
    Jun 1, 2011
    Location:
    United Kingdom
    #9
    I'm pretty certain that isn't it too. I've iMessaged people I don't have an email address for... it just uses their mobile number.
     
  10. luke.mac1 macrumors member

    Joined:
    Jun 1, 2011
    Location:
    United Kingdom
    #10
    Think I may have worked this one out.
    I looked at the settings on the phone that wouldn't receive iMessage to phone number. Checked settings -> messages. Under iMessage, receive at was only set to email address...
    Could this be because the apple ID does not contain the mobile number? Also, this phone is yet to be synced with a computer, so maybe this is the issue?
    Will post again when it has been synced with a computer.
     
  11. MSmith1915 macrumors newbie

    Joined:
    Mar 8, 2008
    #11
    Might want to check your account with AT&T (?) to see if her messaging billing got transferred to the upgrade on the 4S. When I upgraded from the 3GS to the 4S I was given a couple of options to select on my account, the first was my unlimited data which I selected first. It did not allow me to go back or select later the messaging plan. I did that later after I got my 4S on AT&T's website.
     
  12. luke.mac1, Oct 16, 2011
    Last edited: Oct 16, 2011

    luke.mac1 macrumors member

    Joined:
    Jun 1, 2011
    Location:
    United Kingdom
    #12
    Fix for me:
    Plug iPhone into iTunes, set up properly with Apple ID. Sync the phone. Then go to settings -> messages and if the phone number still hasn't appeared under receiving address, turn iMessage off and on. The phone number appears under receiving address. Next, turn the phone that couldn't send iMessages to the phone that couldn't receive them off and on.
    Hey presto! Everything works!
    I hope that works for some others who are having the same problem.
     
  13. sdlevi27 macrumors regular

    Joined:
    Oct 22, 2008
    #13
    Had the same problem last night (friend could iMessage me, but if I started the message it was sent as SMS). Rebooting the my phone fixed it.
     
  14. Stonegrind macrumors newbie

    Joined:
    Nov 21, 2011
    #14
    I had this same problem, it was also between my wife and I. Your solution solved the problem, thanks ! I had to turn iMessage on and off to discover the settings.
     
  15. sathish353 macrumors newbie

    Joined:
    Apr 17, 2012
    #15
    urn iMessage off and on

    "turn iMessage off and on" worked for my iphone4, before doing this I've updated the mobile number at my apple account.
     

Share This Page