WiFi channel disappears when I tried to connect to a 5Ghz WiFi

Discussion in 'MacBook Pro' started by pitiphong.p, Jul 28, 2015.

  1. pitiphong.p macrumors newbie

    Joined:
    Jul 28, 2015
    #1
    I have a Retina MacBook Pro 13" 11,1 model. I found that I can't connect to my friend WiFi 5Ghz. network so I tried to take a look at it and found some weird.

    1. At first my MBP can see 5Ghz WiFi network but when I try to connect it, it failed and after that my MBP can't see that network again.

    2. I have to remove some configuration in "/Library/Preferences/System Configuration" folder then restart. After restarting my MBP can see that network but failed to connect and then can't see it again.

    3. I took a look at System Information. In the WiFi section I saw the supported channels data.

    3.1 Before I try to connect that 5Ghz network and while my MBP can see that network the supported channel listed 165 (which is the channel that WiFi using)

    3.2 After I try to connect and failed, the 165 channel disappear from the supported channel list



    Is this a hardware issue or software and how can I fix it?



    Machine Information

    - Retina MacBook Pro 13" 11,1 model

    - OS X El Capitan beta 4

    - Note that this issue occurred since Yosemite 10.10.3


    MacBook Pro with Retina display, OS X Yosemite (10.10.4)
     
  2. zombiecakes macrumors regular

    Joined:
    Jul 11, 2012
    #2
    if you are going to use 165 the router probably needs to be set to 40mhz or 20mhz (whichever it is not set to right now), or just pick a lower channel
     
  3. pitiphong.p thread starter macrumors newbie

    Joined:
    Jul 28, 2015
    #3
    It already use 165 channel with 20Mhz. band. The weirdo is that my friends can connect to it and I can connect it after restarting my computer once. After that I can't :(
     

Share This Page