WiFi drops if "overloaded"—have to turn Airport Off & On to re-start connection

Discussion in 'macOS' started by BlueberryMac, Jul 10, 2010.

  1. BlueberryMac macrumors member

    BlueberryMac

    Joined:
    Aug 25, 2009
    #1
    Hi there.

    I used to have a problem with my late-2006 13" white MacBook where, if I opened up a bunch of Safari tabs/windows at a time, or a bunch too quickly, or was downloading podcasts with iTunes and opened up another internet-dependent app—my wireless connection would drop.

    I would still see the full signal strength in the menu bar (all four "bars" of that rounded signal monitor), but the Up and Down activity would drop to 0.

    The only way to re-start the connection was to click on the signal monitor, select Turn Airport Off, and then just select Turn Airport (back) On.

    Only then, would the connection come back on.

    This was a pain, especially if I was in the middle of a big download, as I usually had to restart the whole download.

    Anyway, I recently upgraded to a new MacBookPro and used the Migration Assistant app to move all of my info and settings over. Unfortunately, the "wireless dropping when there are too many things trying to be accessed from the internet" problem seems to have come over to the new machine via the Migration.

    Can someone tell me, if there's a preference file(s) I can I trash, or rebuild, or whatever to fix this problem?

    If there isn't a pref file to trash, might creating a new user solve it? I'm half-ready to do a full reinstall of Snow Leopard, but then I'm going to have to move all of my iPhoto/iTunes/Mail stuff around... it'll be a huge pain just to try to get around this one thing...

    By the way, my wireless router is a
    "Cisco-Linksys WRT54G2 Wireless-G Broadband Router" (802.11g), but I don't think the problem is on the router's end—as I don't have to go and turn the ROUTER off, it's always toggling the airport connection off-and-on via my MacBookPro.

    Suggestions?
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #3
    This sounds like a classic "Macbook WiFi Problem" case. It is one of the many issues that affects the Macbook /Pro Airport. There are lots of voo doo fixes out there. After trying a bunch of them on my 07 Blackbook, I found out that changing the encryption to WPA or WPA2 helped. Also if your router has the "wide channel" or "20/40Mhz" setting, you should set it so that it does not use wide channels or to 20Mhz only. Another, almost creepy, fix is to use an Apple Airport base station. They seem to produce less problems then other ones.
     

Share This Page