WiFi frustrations with my 2016 MBP running High Sierra

Discussion in 'macOS High Sierra (10.13)' started by bbates123, Mar 25, 2018.

  1. bbates123 macrumors 6502

    Joined:
    Jul 2, 2010
    #1
    The wifi on my MBP (running 10.13.3) was getting progressively worse and worse. Sometimes it would auto connect to wifi networks I had previously connected to and sometimes it wouldn't. I tried everything I could find...deleted files from /Library/Preferences/SystemConfiguration/, reset SMC, PRAM, NVRAM, created custom MTU/DNS, etc. etc. Finally I found something on bluetooth sometimes creating problems. I had 2 sets of AirPods in Bluetooth and when I removed one of them it seemed to fix the issue. For a while. Then the problems started happening again. So I said screw it, I'm just going to reload MacOS from scratch...deleted the partition and did a clean install and that finally fixed it. Well, mostly...

    My MBP almost always now connects to my home and work wifi networks automatically. Where I run into issues is with public wifi...like hotels, lounges, Gogo Inflight, etc. etc. When I go into network preferences I see that all of the sites that I'm trying to connect to have Security set to "None" (vs say, WPA2 Personal) so I suspect it has something to do with that. In most cases I literally have to turn wifi off, turn it back on again, then select the access point.

    Has anybody else run into this? Any way around this? It wouldn't be so bad if I didn't have to constantly turn off wifi, turn it back on, and re-select.
     
  2. bbates123 thread starter macrumors 6502

    Joined:
    Jul 2, 2010
    #2
    Any thoughts on this? I can definitely live with this but it's quite annoying, especially when this doesn't happen when I boot into Windows.
     
  3. Voenix Rising macrumors member

    Voenix Rising

    Joined:
    May 1, 2013
    #3
    I've had this problem only with our Guest Wi-Fi at work. At home it's rock-steady, leading me to believe there's something wonky at work even though the access point was just replaced. I know this doesn't answer your question, but only to let you know you're not the only one having issues.
     
  4. bbates123 thread starter macrumors 6502

    Joined:
    Jul 2, 2010
    #4
    FWIW..some more strangeness... Stayed at the Kendall Hotel in Cambridge MA this past week. Like before, every time I would wake the MacBook I would have to turn Wifi off, turn it back on, and re-select my access point and wait 10 seconds. But when I had my MacBook plugged into power, every time I woke it, it automatically connected to my access point, that was a new wrinkle. It was only an issue when it wasn't plugged into power.

    So last night I stayed at a Hilton. Same deal as before, had to turn Wifi off, then back on, then re-select the Hilton access point and wait about 10 seconds for my MacBook to make the connection. Being plugged in to power made no difference in this case.

    As I mentioned before, this is a clean install. The only thing I loaded that didn't come with the laptop was Microsoft Office and xSee (photo viewer), and this is never a problem with my home or work wifi networks...connects to wifi right away with no delay whether on power or not. (That was not the case till I did the clean install)
     
  5. SoGood macrumors 6502

    SoGood

    Joined:
    Apr 9, 2003
    #5
    Sounded similar to my issue on multiple macOS and iOS devices from around the time of 10.13.3. In my case, had problems maintaining connection and inability to connect with repeated request for password. It was also inconsistent. I was pulling my hairs out after trying my bag of tricks, but was only finally solved with the latest macOS 10.13.4 and iOS 11.3. So far so good.
     
  6. Voenix Rising, Apr 5, 2018
    Last edited: Apr 5, 2018

    Voenix Rising macrumors member

    Voenix Rising

    Joined:
    May 1, 2013
    #6
    YES! I have this exact same problem with my 2016 MBP when connecting to the Guest Network at work. It was so bad I even had them replace the access point, thinking it was going bad. It worked fine for a while thereafter, but for the past few weeks the problem has returned in force. No one else connecting to the Guest Network seems to have a problem, and my iPhone stays connected all day with no problem.

    I wish I could offer a solution, but the only one I've found is what you're doing. At least you're not alone...
     
  7. bbates123 thread starter macrumors 6502

    Joined:
    Jul 2, 2010
    #7
    I would think that there would be a lot more people complaining about this issue. Maybe there's still something in the cloud (keychain?) that carries over even after I do a completely clean install that's screwing me up. Again, it's only public access points where security is set to "none" instead of say, WPA2.
     
  8. friednoodles Suspended

    Joined:
    Feb 4, 2014
    #8
    Installing 10.13.4 fixed this issue for me.

    I had the same symptoms with my late-2016 MBP, and it similarly started with High Sierra. I assume it must have only affected a very small number of people or we would have seen widespread reports. Basically it wouldn't reconnect automatically to WiFi networks or would take an extremely long time to do so. Turning WiFi off and back on would make it reconnect faster, but even then it often took more than 20 seconds to find the network. I'd similarly tried resetting things, deleting pref files, deleting all iCloud Keychain entries, etc - nothing helped, so I decided to just put up with it (which was painful). I don't know if it had security set to "none" though, as I didn't think to look for that.

    But, after a week of having 10.13.4 installed, it seems like the problem is gone.
     

Share This Page