Ansath

macrumors 68030
Original poster
Jun 9, 2018
2,574
2,092
England
The last couple of days, I’ve had to re-enter my password multiple times a day, sometimes my iPhone won’t see my WiFi network, but the iPad will (both want me to enter password again though). Never had this before.

Anyone else seeing this? (I’ve fed it back to Apple).
 
  • Like
Reactions: LlamaLarry

oodi

macrumors regular
Sep 26, 2015
128
47
I dont have wifi password issues but wifi is unstable on my 11 pro max trying to reconnect many times during the use.
 

1193001

Cancelled
Sep 30, 2019
207
196
same issue with iphone x for 2.4ghz but also unstable wifi but on my ipad ios 14 seems great
 

thewhitehart

macrumors 65816
Jul 9, 2005
1,032
396
The town without George Bailey
I’ve had my iPhone 7 and iPad 6 gen. forget the password for my home WiFi network sometimes when disconnecting and reconnecting. I especially noticed this after a reset of both devices. They also forgot other WiFi networks previously remembered.

Somehow my MacBook Air, which is running the latest version of Catalina, also forgot my home WiFi network and failed to connect to new networks previously joined by the iPhone and iPad. Could the iPhone or iPad have reset some sort of common keychain used by all devices?
 

OverSpun

macrumors 65816
Sep 12, 2006
1,109
81
California
I am experiencing this issue since iOS14 came out. I often have to put in my wifi password but there has not been any wifi SSID or Password changed since iOS14.
 

Ansath

macrumors 68030
Original poster
Jun 9, 2018
2,574
2,092
England
I am experiencing this issue since iOS14 came out. I often have to put in my wifi password but there has not been any wifi SSID or Password changed since iOS14.

I think it was Private Address that was the issue. Disabling it for my home wifi and it was then fine.
 

OverSpun

macrumors 65816
Sep 12, 2006
1,109
81
California
Disabling Private Address did not resolve the issue after more than a week. I had to put in my wifi password again. There must be a bug in 14.0.1...

I do not want to restore the phone for this because that would take a lot time.
 

foonon

macrumors member
Aug 4, 2007
52
12
I am seeing similar flakiness with 14.1. Wi-Fi is seen to be disabled in Settings, but it is still on and connected to my home Wi-Fi network.
 

foonon

macrumors member
Aug 4, 2007
52
12
I fixed it by resetting the network settings. Issue didn’t come back since.
I tried that...no luck.

However after I installed 14.2 and then restarted with Airplane mode enabled and then turned off Airplane mode after the reboot, we seem to be back to normal.

~f
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.