WiFi on iPhone X automatically turns back on after restarting phone.

PCtoMAC1

macrumors 6502
Original poster
Mar 16, 2012
333
105
Is anyone else experiencing that issue? I have WiFi turned completely off in settings, though it turns on when I reboot my phone. It didn’t do this prior to the recent iOS update.
 

PCtoMAC1

macrumors 6502
Original poster
Mar 16, 2012
333
105
There’s a huge thread on this already.
Please note the thread, that would help me save a ton of time. Note, this is not the same as not being able to turn off WiFi from control center.

Thank you!
 

ms_november

macrumors newbie
Nov 21, 2018
1
0
Please note the thread, that would help me save a ton of time. Note, this is not the same as not being able to turn off WiFi from control center.

Thank you!
[doublepost=1542866593][/doublepost]Please forgive any mistakes I may make here - first time on this site and I'm trying to see if there is an option to have my iphone x re-start WITHOUT wifi for troubleshooting other issues (time zone changing on me). Has anyone found a way to re-start the phone without wifi starting up and without re-setting it, just to troubleshoot? I'm trying to determine if the time zone issue is with Sprint or Xfinity. Having this issue on both an android and an iphone, both connected to our wifi network.
[doublepost=1542866684][/doublepost]
[doublepost=1542866593][/doublepost]Please forgive any mistakes I may make here - first time on this site and I'm trying to see if there is an option to have my iphone x re-start WITHOUT wifi for troubleshooting other issues (time zone changing on me). Has anyone found a way to re-start the phone without wifi starting up and without re-setting it, just to troubleshoot? I'm trying to determine if the time zone issue is with Sprint or Xfinity. Having this issue on both an android and an iphone, both connected to our wifi network.
I've switched wifi off in the settings menu, but it keeps coming back on anyway. I tried re-starting it in airplane mode but it only restarted without cell service and switched the wifi back on!