Wifi turns off after X amount of hours of 'sleep'

Discussion in 'iPhone Tips, Help and Troubleshooting' started by clee290, Oct 5, 2015.

  1. clee290 macrumors member

    Joined:
    Oct 28, 2010
    #1
    Hi everyone,

    So I've been experiencing something with my new 6S that is bugging me. Whenever I wake up in the morning, I notice that my wifi is not connected and no new mail notifications (which isn't normal). Then when I unlock my phone, wifi connects and mail notifications come in.

    I do not have 'Do Not Disturb' scheduled, nor do I enable it before I sleep.

    I don't believe this is an issue with the Mail app as it works fine during the day.

    I haven't done any rigorous testing yet, but it seems that the wifi turns off after a few hours without use. I guess this makes sense to save battery, but I don't remember this happening with my iPhone 5.

    I should note that I do have Background Refresh turned off and Mail set to fetch every 30 minutes. Could my Background Refresh setting be messing with the Fetch setting? Again, I get notifications normally during the day, which is why I don't believe this is the problem. I mighty enable it later tonight to see if that fixes it.

    Has anyone experienced something like this? Or does anyone know what might be the problem?
     
  2. ckc macrumors regular

    Joined:
    Nov 13, 2010
    #2
     
  3. ckc macrumors regular

    Joined:
    Nov 13, 2010
    #3
    wifi turns itself off after the phone goes into sleep mode after a few minutes.

    The only exception is if the phone is connected to a mains power source in which case it remains on.
     
  4. clee290 thread starter macrumors member

    Joined:
    Oct 28, 2010
    #4
    Thanks for the reply. The strange thing is, I do usually have my phone charging overnight. So if what you're saying is true, then the wifi shouldn't be turning off at all. Very strange.

    ------------------------

    Anyways, currently running a little test. Haven't touched my phone for a few hours and sending myself emails every so often and going to see when I stop getting notifications.
     
  5. clee290 thread starter macrumors member

    Joined:
    Oct 28, 2010
    #5
    Well, the results my initial test weren't good. As I said, I left my phone untouched for a few hours, sent myself emails (from my Macbook/computer) and I ended up receiving no notifications.

    I was searching here and Reddit and saw someone mention something about passcode/TouchID, so I ended up disabling that and enabling Background App Refresh (felt that Mail fetch might depend on that). Sent myself an email and eventually got the notification.

    Turned off Background App Refresh and turned on my passcode (no TouchID). Sent myself an email and eventually got the notification.

    Turned TouchID back on. Sent myself an email and eventually got the notification.

    And when I woke up this morning, I had my Mail notifications right there on the lockscreen.

    So overall, I have no idea what changed, but it is now working as I expect it to.
     

Share This Page