WiFi Wont remember ? Anyone Else?

harleymhs

macrumors 6502
Original poster
Jul 19, 2009
468
25
I have an iphone 5 .. it seems that it wont remember any networks that I joined.. and will not ask to join networks as well.. I go to my office, add the network password, then come back later after I leave and it wont join automatically! It doesnt say " Forget this Netowork" either on the netowrk settings! So if it doesnt say forget this network, its safe to say it didnt remember it from the start.. Anyone else have this issue? Apple was NO HELP what so ever after being on with them for 20 min..
 

ttravis78

macrumors newbie
Oct 15, 2011
7
0
My Iphone 4S does this too on iOS 6. It does my wifi at home just fine but won't remember my work wifi.
 

harleymhs

macrumors 6502
Original poster
Jul 19, 2009
468
25
UPDATE.. I was on the phone with Apple for an hour. they have NO CLUE why this is happening.. So I played around with the settings and now my office network has the "forget this network" which in fact it does remember it now! What I did was I turned on notify me of avaiable netoworks, I switches cellular data off, then I powered my phone back on, went to safari and it asked me to join a netowork, I picked my office network, didnt ask me for a password, connected to safari via WIFI and went back to turn cell data back on, went back to netowrk settings and NOW the FORGET this netowrk is on the settings screen! Now I turned phone off and on, and the phone joined my office netowrk fine! Once I saw REMEMBER this netork on the network I knew it was working.. Now Ill CHECK to see if my home network will do the same..
 

Mliii

macrumors 65816
Jan 28, 2006
1,126
3
Southern California
Try this:

1. Turn off WiFi
2. Turn on WiFi
3. Select "Other" - not YOUR network
4. Manually type in YOUR network name
5. Select the password type and then enter your password.

It should remember it from that point on.
Please let us know whether this helps.
 

Kcz85

macrumors newbie
Sep 27, 2012
1
0
My iPhone 5 was doing the same thing. I just came back with a replacement from the apple store. Same problem. Rather than selecting the available network and entering the password I manually entered the network details... It has worked!!! I have been turning on and off wifi for the past half hour and it's automatically connecting. Hope this helps!! #
 

Tom8

macrumors 6502a
Oct 28, 2010
848
71
Try this:

1. Turn off WiFi
2. Turn on WiFi
3. Select "Other" - not YOUR network
4. Manually type in YOUR network name
5. Select the password type and then enter your password.

It should remember it from that point on.
Please let us know whether this helps.
Excellent. I can confirm this has worked on my iPhone 4 running iOS 6. Where as before when i tapped on the network it would prompt me to enter my password, but would not remember the WiFi.
 

ttravis78

macrumors newbie
Oct 15, 2011
7
0
Try this:

1. Turn off WiFi
2. Turn on WiFi
3. Select "Other" - not YOUR network
4. Manually type in YOUR network name
5. Select the password type and then enter your password.

It should remember it from that point on.
Please let us know whether this helps.
This did not work for me, still having the problem.
 

davehutch

macrumors 6502a
Mar 5, 2009
671
20
Croxley, Herts
Same issue.
Hoe is fine (Virgin Superhub), but work doesn't seem to join automatically.
If I try to list the networks, it doesn't see any, until I switch Wi-Fi off and back on again and then they all list straight away and it joins.
 

acientblack

macrumors newbie
Dec 15, 2012
1
0
UPDATE.. I was on the phone with Apple for an hour. they have NO CLUE why this is happening.. So I played around with the settings and now my office network has the "forget this network" which in fact it does remember it now! What I did was I turned on notify me of avaiable netoworks, I switches cellular data off, then I powered my phone back on, went to safari and it asked me to join a netowork, I picked my office network, didnt ask me for a password, connected to safari via WIFI and went back to turn cell data back on, went back to netowrk settings and NOW the FORGET this netowrk is on the settings screen! Now I turned phone off and on, and the phone joined my office netowrk fine! Once I saw REMEMBER this netork on the network I knew it was working.. Now Ill CHECK to see if my home network will do the same..

Thank you so much , i tried exactly what you said and IT WORKED !! THANK YOU