WiFi works on everything but my mac, even other people's macs

Discussion in 'MacBook Pro' started by Earl Dukes, Mar 26, 2013.

  1. Earl Dukes macrumors newbie

    Joined:
    Mar 26, 2013
    Location:
    Panama City, Panama
    #1
    The title says it all. I've tried everything. I've tried resetting everything I can, I've done all the stuff on this list:

    http://macosx.com/forums/howto-faqs...airport-card-settings-os-x-10-7-x-10-8-x.html

    Did all that and then some, and wifi still does not work. It works momentarily, but after a minute or so, it stops working. During the initial set-up, I tried connecting in the normal way by choosing the network and entering the password, but it kept taking me through set-up wizard type things, which seemed abnormal. After half an hour trying to figure out why it wouldn't let me connect, it randomly started working but, as I said, very poorly. As I stated in the title, the network works perfectly on all other devices, including other macbook pros. This is very confusing, and any help would be appreciated.
     
  2. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #2
    Sounds like you have a wireless card hardware issue. Some work until they heat up enough to break a connection ( defective solder). Still have a warranty?
     
  3. Serban Suspended

    Joined:
    Jan 8, 2013
  4. MrMacMack macrumors 6502a

    Joined:
    Oct 24, 2012
  5. cookiesnfooty macrumors 6502

    cookiesnfooty

    Joined:
    Jul 1, 2009
    Location:
    Harrogate
    #5
    Could be hardware or software related.

    Have you tried wifi in multiple locations to rule out Wifi isn't locking out your MAC address?

    DHCP is on or set manually?

    try reset these if so.
     

Share This Page