windows media player version X for MAC Install

Discussion in 'Mac Apps and Mac App Store' started by MightyB, Mar 3, 2003.

  1. MightyB macrumors member

    Feb 27, 2003
    Gilbert, AZ
    hey guys....i've got a 12" PB running OS X.2.4 and I am trying to install windows media player for version X. (i know, i know)...

    anyway, when I launch the installer, the authenticator comes up and I put in my password...then it just stops. :-(

    I check my "windows media installer.crash.log" log, and I get this:

    Date/Time: 2003-03-03 21:50:38 -0500
    OS Version: 10.2.4 (Build 6I32)
    Host: Brian-Brodeurs-Computer.local.

    Command: Windows Media Installer
    PID: 510

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000006

    Thread 0 Crashed:
    #0 0x90134d80 in CFGetTypeID
    #1 0x0020a9a8 in 0x20a9a8
    #2 0x0020aec0 in 0x20aec0
    #3 0x001e8d54 in 0x1e8d54
    #4 0x001eaa50 in 0x1eaa50
    #5 0x001ead78 in 0x1ead78

    PPC Thread State:
    srr0: 0x90134d80 srr1: 0x0000d030 vrsave: 0x00000000
    xer: 0x00000000 lr: 0x90134d70 ctr: 0x90134d60 mq: 0x00000000
    r0: 0x0020a9a8 r1: 0xbffff420 r2: 0x9017d18c r3: 0x00000000
    r4: 0xa1b1c1d3 r5: 0x00000000 r6: 0x00000000 r7: 0x00000000
    r8: 0x00000000 r9: 0xa0001048 r10: 0x00000000 r11: 0x00000100
    r12: 0xa0136480 r13: 0x005dc394 r14: 0x005dc892 r15: 0x005dc37c
    r16: 0x005dc898 r17: 0x005dc7dc r18: 0x005dc900 r19: 0x00000000
    r20: 0x00000000 r21: 0x00000000 r22: 0x005dc898 r23: 0x0000023f
    r24: 0x00000002 r25: 0x00000000 r26: 0x00000000 r27: 0x005dcc74
    r28: 0x005dc896 r29: 0x00000000 r30: 0x00000001 r31: 0x90134d70 seems like when I look at my console log, there seems to a lot of "enable to bind to parent errors". Is that and "EXC_BAD_ACCESS" my problem???

    I've run the disk utility and "repair disk permissions" a number of times...each time there are "errors", but I am still unable to install...(I've managed to install other programs withouta probelm)

    I feel that I've configured something wrong....I've only been a "switcher" for 4 days!
    I did have one problem where safari, explorer were crashing and other odd things were happening such as missing objects on the dock bar...(just fuzzy boxes). I just recreated my preferences and that fixed that...but I don't know if I did something else bad in doing so.

    thanks for you help!

  2. TEG macrumors 604


    Jan 21, 2002
    Langley, Washington
    1) If you haven't done it yet, and you can backup any of your personal files. I suggest you reinstall your system, using your "System Install" CD. There are sometimes errors in the system that Apple Installs. However it is less often then Dell or HP.
    2) Try redownloading the .dmg file, M$ servers aren't the best in the world, they have a high number of corruptions.
    3) Try a 3rd party Media Player. I personally don't use one, so I can't recomend one but maybe another member can.

  3. yzedf macrumors 65816


    Nov 1, 2002
  4. MightyB thread starter macrumors member

    Feb 27, 2003
    Gilbert, AZ
    yes...i have repaired permission...

    still same there anything else to try before I use the restore disc? I don't want to have to re-install the apps I have installed, reconfigure all my preferences, and move over all my pc files again! :-(

  5. Sherman macrumors regular

    Jul 23, 2002

    Okay, first of all, i'm going to save you a lot of pain and flaming and telling you that you should just type "mac" not "MAC" it's not an acronym or something.

    About your problem though, it sounds like it's looking for a file/resources that's not there, and since ms programmers are notoriously lazy, they didn't think that would ever happen and didn't put a condition in the programming for that.

    Just try re-downloading it. If not IM me and i'll send you my copy. That installer is **** anyways, all it does is unpack the program.
  6. MightyB thread starter macrumors member

    Feb 27, 2003
    Gilbert, AZ
    I have tried downloading it a couple of times...all with the same result...

    I feel like I have a bigger problem though...
  7. richie macrumors member

    Jul 16, 2002
    Melbourne, Australia
    That's the good thing about the Jaguar reinstall - you can just choose an option in the reinstall that will move over all the existing users and preferences to the newly installed system. That means your prefs, your docs (in your Home folder) will already be moved, and possibly your installed applications (not sure about that one).

    It sounds like your system may need reinstalling, as has been suggested.. :/ It's unfortunate, but sometimes these things happen.
  8. SBG88 macrumors regular


    Feb 19, 2003
    Same kinda crap happened to me when I tried to install wmp on my ibook. Installed fine on my iMac, but here's what I did..

    Apparantly the installer put a bad file on my system. Open the finder and search for windows, and/or media, media player and trash all files associated with wmp. Be careful if you have another media player installed.

    I bet that works, did for me.
  9. Fukui macrumors 68000


    Jul 19, 2002
    OK, I had some problems with WiMP.
    Like the previous guy said try and search for any files that the installer might have left on your system (like some preferences or something that it refers to), microsoft like to use the installers by third-parties (Vise Installer), and it is notoriouslly doesn't like it if you've "customized" (made not normal changes) to your system such as moving users to other partitions or using Unix File System instead of HFS...

    Also, if you install a program with Vise, and you have a mounted network disk, make sure to eject the disk or else the installer will SCAN all the drives you have mounted including the network connection...and it will take forever.

    P.S You might want to try MPlayer OSX, it is a Unix/Linux player that can play alot of media including .ASF .ASX .WMA and DiVX.

    As a LAST RESORT, rename your ~/library folder (the on inside your home directory) log out, log-in, and run the installer, most likely it will work.
    Afterwards, delete the new Library folder that was automatically created, and rename the original back to "Library," log-out, then log-in again, everything shoulld be back to normal....

    And contrary to many posts, OS X is not windows, you dont need to re-install the system if you encounter errors, 90% of the time, the problems are usually just constricted to your own particular "user..."
  10. ShaolinMiddleFinger macrumors 6502a


    Oct 12, 2001
    Go Download VLC Media player on Versiontracker. It can play Windows Media on OSX.
  11. MightyB thread starter macrumors member

    Feb 27, 2003
    Gilbert, AZ

    well folks...I tried everything that was suggested and had no luck...

    I even recreated preferences for my user, and nothing...

    So I finally just created a new user with admin priveledges for the heck of it...and wouldn't you know it, IT WORKED!!!

    Unfortunately I don't know why...seems like something in my primary "user" is messed up....but I'm not sure where to even start....

    Any suggestions???

    In the meantime, I'll probably just copy my apps and docs from the one user to the new user and leave it at that...

  12. Fukui macrumors 68000


    Jul 19, 2002
    You mean the original user didn't have admin privilages? If so, then that was the problem most likely I guess...
  13. MightyB thread starter macrumors member

    Feb 27, 2003
    Gilbert, AZ
    No, the origanal user DID have admin priveledges! I just created a new user, with the same exact priveledges, and it worked...

    something isn't right with my first user.

Share This Page