Windows Networking Problem Sorry!

runninmac

macrumors 65816
Original poster
Jan 20, 2005
1,494
0
Rockford MI
Sorry I still have a windows PC (dont flame me :p im working on getting a iMac) but at the beggining of last week certain webpages wernt loading aka Macrumors and Gmail. Also some webpages would just looked screwed up like the Applestore and Macrumors Forums. So today I unpluged my router and just used the ethernet connection and everything worked correctly! I was amazed so Im wondering how do I make my router work normaly again? Should I push the reset button on the back? I just want to make sure I dont screw things up.

Thanks in advance
 

pdpfilms

macrumors 68020
Jun 29, 2004
2,383
0
Vermontana
I am not flaming you. But it may be difficult finding support for your windows machine(s) on this website. Try pcrumors.com.
 

ChrisBrightwell

macrumors 68020
Apr 5, 2004
2,294
0
Huntsville, AL
His question was more about his router than it was his PC.

To the OP: Try resetting the router and making sure it's got the latest firmware updates. I've seen routers do weird things in the past, but the reset and upgrade (if needed) almost always sort out the issues.
 

Calvinatir

macrumors 6502
Nov 8, 2003
430
0
LA
something similar started happening on one of my client's networks. Lots of sights weren't loading correctly so I connected directly and everything was fine. I reset and reflashed the firmware of the router and that did not help. Turned out after a few minutes on the phone with LINKSYS that it was a lossy/faulty router.
 

ITASOR

macrumors 601
Mar 20, 2005
4,398
3
This happens all the time. Resetting might help if you're lucky. Make sure to hold it for AT LEAST 1 minute no matter what they say. Less than 1 minute sometimes doesn't do anything. I've been through 4 WRT54G's in the last 2 months. Walmart's electronic return center practically calls me by my first name.