Wireless stopped working when we bought a new router!!

Discussion in 'Macintosh Computers' started by kms, Nov 2, 2003.

  1. kms macrumors newbie

    Nov 2, 2003
    For years I have been using my G4 Titanium (1st generation) laptop with an AirPort Card and a Linksys base station. It worked form day one - no problem!

    We updated the firmware for the Linksys this week and everything went bad. My husbands 2 PC's stopped getting out to the network, then one worked, one didn't, etc. My Mac never worked.

    Today my husband decided to buy a new router to solve his problem. We got a D-Link. The D-Link works perfectly for his wired desktop and wireless laptop.

    Now for my mac...

    1. the router works fine if I am plugged into it, but not wirelessly.
    2. I am picking up a strong wireless signal from the router.
    3. I can not access the internet
    4. When we "ping" the IP address, it sends no packets
    5. I am using DHCP and getting an IP address from the router

    We have tried everything!! I have networking experts as friends and they can't figure anything out either. D-Link tech support was clueless - they say it's a Mac thing, not a router problem.

    My "theory": My OLD Airport card has something in it that does not enable it to work with updated routers. It started to fail as soon as we updated our old router's firmware, so could this be???
  2. Thirteenva macrumors 6502a

    Jul 18, 2002
    Try going into network preference panel, then under airport settings. Where it says what network to join, pic 'join a specific network' then choose or type in the name of the network you want to join (case sensitive). This should force it to join the network. By default it is set to 'any' I believe or 'strongest signal'. Either way this can be a problem if you have a cordless phone that runs at 2.4ghz. I've picked up our phone signal with my airport card before and it will show a signal strength but you won't be able to do anything.

    Another issue may be if you are using encryption. If you are using 128 bit encryption then in the text box where you put your wireless password put a $ dollar sign as the first character then type the password.

    I believe a 40 bit encryption password requires single quotes at beginning and end but don't quote me on that, i've never used 40 bit with airport.
  3. kms thread starter macrumors newbie

    Nov 2, 2003
    Thanks for the suggestion - the only thing is that we haven't enabled passwords or encryption yet. We were waiting until I got connected to mess with those settings. It's on a basic setup as of now.

    And BTW, the wireless connection to the Linksys at work is fine - no problems at all!
  4. Thirteenva macrumors 6502a

    Jul 18, 2002
  5. kms thread starter macrumors newbie

    Nov 2, 2003
  6. Thirteenva macrumors 6502a

    Jul 18, 2002
    Hmmm... now i'm baffled. I know panther has some wireless issues that were posted on apples discussion forums.

    I'll give this some thought, and see if i come up with anything else.
  7. iriejedi macrumors 6502a


    Oct 4, 2000
    Nor Cal

    Not toally the exact problem - but I saw this with a similar issue.

    I bought the wireless router (lynksys) and an access point (ethernet for Xbox) and it quits from time to time. Usually after a time not in use. I refresh the access point (unplug it) and when it comes back on it finds the router and everyone is happy.

    My theory is that this has something to do with the ISP's IP info being dynamic (at least for COmcast cable access) and the message not always getting to every periferal... so you have to tell the access points to go get new information.

    This may or may not help. This may or may be right but I had that problem at first... and ths solved it. Maybe it can help you out too.

    Best of luck.

  8. ftaok macrumors 603


    Jan 23, 2002
    East Coast
    Re: solution?

    I don't think the dynamic IP is the problem. I might be wrong, but I think that once the router is given an IP addy from Comcast, the IP address stays the same until the address is released.

    It's probably due to some sort of encryption that got turned on by default. Try disabling all encryption first.

    Also, the router may not have the Mac in its "access list". Try adding the Mac to the list.

    I'm not sure how either of these things are done with a Linksys or D-link router. It's easy with a Netgear router.
  9. madru macrumors member

    Jun 11, 2003
    is the mac filtering enabled in the router? If it is, make sure that the airport mac address is in the list.
  10. kms thread starter macrumors newbie

    Nov 2, 2003
    We have checked and there is no encryption turned on. There is no MAC filtering enabled either. All default settings.

    When I get home, I think we will turn on encryption and MAC address filtering and see if it works...
  11. Wyrm macrumors 6502

    Jan 7, 2003
    Toekeeyoe, Japan
    Everything sounds like it should work fine, so it is probably configuration:

    Is your DHCP address on the same subnet?
    Try using a static IP on the same subnet (make sure it is not in the DHCP range that your router is trying to provide).
    Can you see the SSID? Is the router configured to broadcast this?
    Is the router configured to only broadcast G, and you use a B?

    On a terminal, type "ifconfig" and you can see the results to show any problems (post it here and we can see the results)

  12. Rezet macrumors 6502a


    Apr 21, 2003
    Connecticut, United States of America
    Ohh please... SSID, WEP DHCP..

    Don't enable WEP at all. Unless you enjoy slow connection.
    Go to that IP address they give you in the manual. Login as ADMIN. Look up your IP address. with DLINK masking and firewall it should show up as 192.xx.xx.xx
    If your first digits are not (192 or 190) dlink is not functioning functioning properly on your computer but rather just acts as a bridge.
    (you can find IP in network settings on your mac)

    Find a Pin or someting sharp and hold reset button on the back of your router for about 15 seconds. restart the computer and go to that website again (from the manual) login again a ADMIN
    Don't put a password there yet. Just type in Admin and click ok.
    DO NOT go to a quick setup option.
    Instead on the left side there are going to be different security options.
    I don't remember which one, but find the one that has ALLOW and DONOT ALLOW to connetc options there.
    Go ahead to your comps and find your airport MAC ID (again in network settings)
    Then put IDs of all your comp in the list and select ALLOW ONLY computers with these MAC IDs to connect. Leave network name as 'default'. Click Ok.
    Then go to main menu and on top select security settings somewhere. and put a login password for your admin account. So the next tim eyou have to comeback to that website, you will have to use a password. Restart comp and it should work. It should also be secure without WEP.

Share This Page