won't boot / can't mount hard drive problems!

Discussion in 'Macintosh Computers' started by eazyc10, Oct 12, 2004.

  1. eazyc10 macrumors member

    Apr 17, 2004
    I was using my powerbook yesterday and it was acting funny (everything would lock up for a bit and then come back to life) Then eventually it froze and gave me this weird screen which I've never seen before and said the machine needed to be rebooted (in multiple languages)

    So I rebooted the machine, and when it loaded it gave me a greyish background with a folder in the middle, and a flashing ? and flashing finder icon which alternate when blinking.

    I did some research and saw that the people who had similar problems were told that it can't find where to boot from. So I put in my restore CD, try to run a repair and verify with disk utility and it says it can't because of a invalid b tree node.

    My question is, how am I to recover my data??? I can't mount the HD. I reinstalled the OS on my external firewire drive but cannot seem to get at the hd data.

    If it can't mount the HD in the os, will I not be able to boot my powerbook as a firewire drive and connect it to another mac? I tried running it on a PC but couldn't get the drivers on Windows to read the drive correctly.

    Please help.. I need to restore at least some of those files!! I have no idea how this happened either.
  2. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    You'll need to pick up a drive utility (avoid Norton)...

    But this generally happens when people avoid doing fsck and DFA on a regular basis.

    The problems cascade until you get to this point.
  3. eazyc10 thread starter macrumors member

    Apr 17, 2004
    umm.. no where have I read needing to do a fsck or dfa daily. If this were such a major issue wouldn't apple warn users about situations like this?

  4. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    I said a regular basis, not daily.

    Like once every month or two.

    Force quiting some apps, kernal panics, and forced restarting of the machine can leave stuff on the drive that needs to be cleaned up.

    Unlike OS 9, unix doesn't always write stuff to the drive immediately -- so doing the above can leave orphaned nodes, file/catalog problems, etc.

    Edit -- considering running fsck is something really easy to do when you boot the machine every now and then, it's worth the hassle.

    Otherwise you get to play with drive repairs programs and/or trying to boot your system into target disk mode and connecting it to another Mac to retrieve your home directory
  5. eazyc10 thread starter macrumors member

    Apr 17, 2004
    I got disk warrior to recover whatever data it could question is what are the file names / extensions to mail app files? I found the library -> mail folder but it doesn't save any of the files contained. Just the mbox files.

    I can't seem to properly restore the mail boxes. Am I missing some other files?
  6. fozy macrumors member

    Sep 4, 2003
    Aspen, CO
    same problem

    I have experienced the exact same thing! After a day of airport traveling my hard drive begins acting up, booting half the time, stalling with spinning beach ball for several minutes and now I'm to the point where I cannot mount the drive under any circumstance.

    I have tried Drive 10, Disk Warrior and Disk utility which are all unable to see this 60gb drive on my 15" PB 1.3. I have also tried fsck.

    Please share any possible solutions.

Share This Page