World Book 2003 crash in 10.3.4 / .5

Discussion in 'Mac Apps and Mac App Store' started by TopGear, Aug 16, 2004.

  1. TopGear macrumors member

    Oct 22, 2002
    .––. .–. .– ––. ..– .
    I almost never run World Book 2003 on my 800 Mhz G3 iBook, but I needed to look something up so I tried to run it about a week ago. It started up, and then "unexpectedly quit."

    This was in 10.3.4. Then I upgraded to 10.3.5. No difference.

    I trashed World Book's preferences folder and restarted. No difference.

    I used the Software Restore discs to re-install the programs and restarted. No difference.

    For the record, Console says:

    2004-08-15 20:58:36.976 World Book[492] An uncaught exception was raised
    2004-08-15 20:58:36.977 World Book[492] *** -[NSCFDictionary setObject:forKey:]: attempt to insert nil value
    2004-08-15 20:58:36.977 World Book[492] *** Uncaught exception: <NSInvalidArgumentException> *** -[NSCFDictionary setObject:forKey:]: attempt to insert nil value

    What does this mean?

    I'm running 640 Mb RAM and I never have more than three or four applications open. Even if World Book is the only application, it still quits.

    Any smart people out there who can tell me how to fix this problem?
  2. Darwin macrumors 65816


    Jun 2, 2003
    round the corner
    When I had an iBook (same specs) it came with 10.2 and one of the software titles was World Book, nice program but when I upgraded to Panther 10.3 it stopped working pretty much like yours, never found out the problem :confused:
  3. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    My highly non techminded sister has an eMac that after I upgraded it to 10.3.4 (from 10.3.3) won't open World Book. Hers comes up with a message that it has unexpectedly quit.

    I tried talking her through re-installing it but no good. We trashed plists etc and still doesn't work.

    I did find an article on Apple's Knowledgebase saying this might happen on Panther (why it should work on 10.3.1 and 10.3.2 and not now wasn't explained) and saying that there was a patch on the World Book site to fix it.
    I think that's
    but unfortunately the server was down last night when my sis tried to d/l it
  4. TopGear thread starter macrumors member

    Oct 22, 2002
    .––. .–. .– ––. ..– .

    Thanks! The update on the Mackiev Web site worked perfectly. Now I know everything I wanted to know about Tanzania...



Share This Page