Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

X on battery icon - Replaced battery, charger, and Magsafe DC-in board already (13" MacBook Pro Late 2011 A1278) - Please help!

oreo2996

macrumors newbie
Original poster
Feb 18, 2021
1
0
Hi!



A couple of weeks ago, my MacBook Pro (13" Late 2011) started to display a X symbol on the battery icon, and the light on my charging cable would only show up as green (never orange). Whenever I unplugged the charging cable, the computer would shut down soon after, indicating that it wasn't able to power the computer without being plugged in.



The first thing I tried (after doing some research) was to reset both the NVRAM and the SMC. For the NVRAM I'm pretty sure it worked properly because it repeatedly rebooted until I let go of the keys, but still the problem wasn't fixed. For the SMC reset, it was difficult to tell whether or not it actually reset the SMC, because after holding the keys for the required time and booting the computer, nothing was out of the ordinary, but I'm not sure if there should be something different that happens that lets you know the SMC was successfully reset or not. Either way, I definitely reset the SMC later on when disconnecting and reconnecting the battery, and that did not fix the issue.



Moving onto hardware, I first started by buying a new battery and replacing it. After installing the new battery absolutely nothing changed (same battery X symbol, shutdown whenever unplugged, charger only showed green light).



Then, I bought a new charging cable (old one was in pretty bad shape, so I was hopeful), and tried that out, and once again nothing changed. New cable still just showed green light (even with new battery), and when I unplugged the cable the computer would shut down, X symbol still on the battery icon.



My latest attempt was to purchase a new Magsafe DC-in board (820-2565-A), which I installed last night following a Youtube tutorial. After putting everything back together, I hit the power button and nothing happened, so then I plugged it in and it powered on (on its own, no power button press). Unfortunately, all of the issues were still present, nothing had been fixed. Not only that, but now when the computer is shut down (and plugged in), pressing the power button does nothing. The only way I've been able to get it to turn on is by disconnecting and reconnecting the battery, and then plugging the power cable in, which results in the computer turning on by itself (no button press). If I then shut the computer down, again the power button still does nothing, and the only way to get it to power on is to reconnect the battery again.



Since replacing the Magsafe DC-in board I've tried all combinations of old and new battery with old and new cable, and get the exact same behavior (only boots up after reconnecting battery and plugging in for first time) without solving any of the power issues I started out with.



So, I'm here looking for advice! And I've now added to the list of issues I've got, so if you have any input on anything I would really appreciate it. Basically:

  1. What else can I try for fixing the original issues? (Battery X symbol, charger shows green light only, shuts down after cable is disconnected)
  2. What might be causing the new issue? (Power button does nothing, only way to power on is to disconnect/reconnect the battery and plug it in, turning it on automatically)


My plan from here is to go in and replace the new Magsafe DC-in board with the old one, as that is the only thing that changed since the new issue (#2 above) started occuring, so at the very least I want to try and get rid of that. Would really like some input from anyone who knows more about this stuff. Could the entire logic board be fried? Is there a way to troubleshoot which components could be causing the failure?



For the record, the only thing done to this MacBook that is out of the ordinary would be about 6 years ago I created a Bootcamp partition that runs Windows, but I haven't even booted into Windows for at least 3 years. Hardware is fully stock, other than the hardware I installed detailed in this post. The computer is running macOS Sierra (Version 10.12.6), which I know is an old OS but when I check for updates it doesn't find anything, so I am guessing anything newer than Sierra is not meant to be applied to my MacBook due to its age.



I appreciate you very much for even reading this far, and if you're able to provide any guidance I'd appreciate you even more! Cheers.



System Report/Hardware Overview:

  • Operating System: macOS Sierra (Version 10.12.6)
  • Model Name: MacBook Pro (13-inch, Late 2011) - A1278 (EMC 2555)
  • Model Identifier: MacBookPro8,1
  • Processor: 2.4 GHz Intel Core i5
  • Number of Processors: 1
  • Total Number of Cores: 2
  • L2 Cache (per Core): 256 KB
  • L3 Cache: 3 MB
  • Memory: 4 GB 1333 MHz DDR3
  • Startup Disk: Macintosh HD
  • Graphics: Intel HD Graphics 3000 384 MB
  • Serial Number (system): C1MGL1UKDV13
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.