X-Plane shared library error

Discussion in 'Games' started by bnemesis, Aug 3, 2004.

  1. bnemesis macrumors regular

    Jul 31, 2003
    I just downloaded X-Plane to see what the excitement was about (both the current stable and beta versions), and when I attempt to launch any part of the program, I get the following error:

    The application "(null)" could not be launched because of a shared library error: "#<X-Plane><X-Plane><OpenGLLibrary><>"

    Any Ideas on what this is about?
    I tried repairing permissions, and it did nothing.
  2. iNetwork macrumors member

    Jul 20, 2004
    New Mexico
    What os/machine are you trying to run it on? X-plane isn't a game though :( Did you read the readme that came with it?
  3. bnemesis thread starter macrumors regular

    Jul 31, 2003
    I downloaded the demo from http://www.x-plane.com
    There was no "README" per-say, but there were instructions which I have poured over. I also searched for answers from the X-Plane knowledge base, google, and searched the forum here.

    I am using a G4 iBook, 1ghz 640mb ram, 32mb radeon blah blah blah with Panther. It meets the system requirements.

    >>"X-plane isn't a game though "
    Now here is a man who takes his simulations seriously:-D
    I wanted to play with it because my wife's uncle (who used to fly but doesnt anymore because of MS) just got a new 17" Powerbook, and I think he would enjoy X-Plane.
  4. iNetwork macrumors member

    Jul 20, 2004
    New Mexico
    Just make sure you extract the archive to somewhere other than your desktop. Typically, the folder with all of the rest of your programs is the best place to put it. I've been using x-plane since the era of the first Nvidia TNT card came out. I use it to practice flying, using instruments and other fun stuff! I take cross country flights that would normally cost $1000 for free. I also set it up to give me cross-wind landings and do touch and go landings.

    If all else fails, you can always e-mail Austin. He presonally responds to each e-mail and the best time to send them is in the evening. He always has an answer, though he doesn't spoon feed you. Austin is an awesome man and his product is one of the best out there. He also actually "simulates" flight using physics, not made up values like Microsoft does.

    Just make sure you update osX, etc. I'm not a lot of help because that error is erratic. Also make sure you're running the X version and not the 9 version.
  5. bnemesis thread starter macrumors regular

    Jul 31, 2003
    I had the folder on my desktop (as i was just trying the program out).
    I trashed that and then tried expanding the file in my Applications folder and got the same error. Ill email Austin and hope he can save me. Thanks!
  6. bayanne macrumors newbie

    Aug 13, 2004
    I have also just found the same problem in Age of Mythology. I'm running 10.3.5 on G5/2ghz.

    Is the other user with the problem also using 10.3.5?
  7. bnemesis thread starter macrumors regular

    Jul 31, 2003
    It turned out that I had some nasty corruption of system files. It think it happened during my update to 10.3.4 where the installer for that update bombed out at the end.

    I rebuilt my system, and updated everything. Now (asides from being faster for some reason), all the games I was having problems with work.

    Try repairing permissions, and if that doesnt work boot from the OS X disk and try Disk Repair.

    I knew that mine was FUBAR when Disk Repair couldnt fix it, and instead gave me errors about keys out of order or something.
  8. pimentoLoaf macrumors 68000


    Dec 30, 2001
    The SimCity Deli
    Made-up values? :eek: What do you mean by that? MS Combat Sim II seems pretty realistic to me, trying to land on a carrier and all.
  9. micvog macrumors 6502


    Sep 10, 2003
    One of the main differences between X-Plane and the MS Flight Sims is that, as iNetwork points out, X-Plane actually calculates the flight physics involved at each point in time (as best as Austin can simplify them). MS instead looks up values in a pre-populated table. Notice I didn't say "pre-calculated"; the values on the table aren't calculated based on flight physics but based on actual observations (e.g. at a certain throttle, pitch, flaps, wind, altitude, etc. your IAS is Y knots).

    You can argue which one is better. Based solely on the Cessnas provided with each program, my experience is that the closer you are to normal flight conditions the more likely MS is "as real as it gets" (e.g. as I mentioned in another thread, the Cessna in X-Plane will rotate counter-clockwise at idle on a runway - totally unrealistic and something that I don't remember ever seeing in MS FS).

    If you want to simulate experimental aircraft, design your own aircraft, fly them on a different planet, fly a plane is extreme conditions beyond which they were designed, etc., X-Plane is reportedly more accurate.

    It's a matter of choice, unless you have a Mac. Then you live with X-Plane and explore FlightGear. :)

    EDIT: Sorry about getting on a soap box, but flight sims are one of the three downsides I have identified for me switching to Mac. The other two are (1) Microsoft Access, although VPC handles that and (2) linear programming programs (again something VPC will handle but with substantial performance issues).

Share This Page