X11 loses xauth / :0.0 connection after sleep

Discussion in 'Mac Apps and Mac App Store' started by parkblvd, Nov 30, 2004.

  1. parkblvd macrumors newbie

    Nov 30, 2004
    Hey all - my iBook's been working fine for months, but one thing is driving me nuts. I'm running X11 (the newest version) on Panther, and I run it in switched mode (fullscreen, use apple-opt-A to get back to the OS) with GNOME/Sawfish. I like to have X open all the time - I do lots and lots of coding. However, I've found that something is causing X to lose its authorization when I put the iBook to sleep (close it), but not EVERY time it happens.

    The symptom is simple enough - when I reopen, relog in (I use a password on wakeup), and switch to X, it's fine, and current windows work, but if I try to run xclock (say), it gives me the typical UNIX "display problem"
    Xlib: connection to :0.0 refused by server
    Xlib: No protocol specified

    Error: can't open display: :0.0

    Does anyone know what causes this? I've got the window manager a little tricked out, but it shouldn't be losing its authorization like this. Restarting X works, but then I have to close and reopen all of my current windows, which is annoying. I'm not a UNIX n00b, and I can't find any mention of this problem online. As I said, it doesn't happen all the time, and I can't find anything it's correlating to. Please help!
  2. Westside guy macrumors 603

    Westside guy

    Oct 15, 2003
    The soggy side of the Pacific NW
    Right now the only help I can offer is to say "you are not alone!" :D

    I always have X11 running (in my case it's in rootless mode). But it's only been just recently (last few weeks) have noticed that I'm seeing the same thing - just often enough to be annoying. I wake the Powerbook up and the Apple X11 appears to still be running merrily along, but when I try launching an X11 app I get that error. I generally don't have any existing X11 windows open during sleep, not that it matters.

    I wonder if it's specific to 10.3.6?
  3. cluthz macrumors 68040


    Jun 15, 2004
    I'm not having this problem. I'm running x11 all the time with GNOME and I have also upgraded to 10.3.6

    If I run x11 for awhile I can't use cmd-tab to switch apps, even if I shut down x11. I have to log out and log in again (in osx).
  4. parkblvd thread starter macrumors newbie

    Nov 30, 2004
    I have this problem as well. I believe the two are distinct. But this is a problem as well!

Share This Page