Xilisoft Video Cutter 2 - problem on Mojave

Discussion in 'macOS Mojave (10.14)' started by wfriedwald, Dec 18, 2018.

  1. wfriedwald, Dec 18, 2018
    Last edited: Dec 18, 2018

    wfriedwald macrumors regular

    wfriedwald

    Joined:
    Jan 1, 2017
    #1
    I have been using Xilisoft Video Cutter 2 for years & years on my older system, currently running El Capitan (10.11.6) - no problem.

    But I would like to be able to also use it on my two Mojave units, my MacBook Air (2014) & the new Mini.

    However, I have the same problem on both of those Mojave machines: the videos, in the cutting screen, do NOT play with the audio! the video plays without sound.

    the workaround is that I view the video in VLC, then make a note of where I want to stop and start, enter those numbers in Xilisoft Video Cutter 2, and then it works fine, but obviously this is awkward!

    I tried contacting Xilisoft customer support, but they don't seem to have any English speaking support representatives, and I don't speak Chinese, alas.

    It's a great little program! making simple edits is (up to now anyhow) very, very simple.

    has anyone else encountered this problem?

    I may ask if anyone can recommend another simple video editor (a trimmer, really) that works in Mojave, although I hesitate to switch because I've already paid for a Xilisoft Video Cutter 2 license.

    thanks as usual!

    w

    PS: am just discovering the power of GALLERY VIEW EDITS, in the new Mojave finder ... very powerful. one can edit down to the frame (I think?) whereas in Xilisoft, one can only edit down to the second, which has usually been enough (thus far...)
     

Share This Page