Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Xls files won't open in Excel


macrumors member
Original poster
Feb 4, 2013
North Yorkshire, UK
Hi. Anyone help? All my xls files will suddenly open only in Openoffice. This is quite a lot of files! Anyone else had this and know how to make them open in Excel again? (preferably by batching rather than opening each one in Openoffice and saving as xlsx!) I'm running a Macbook Pro 2018, on Mojave and Office 2016 (downloaded, not 365). Only happened this last week, and it's driving me nuts! TIA


macrumors 68000
Nov 3, 2004
So do Get Info on one of your XLS files and re-select that they should open in Excel. I'm not where I can look at the dialog box right now but there's a checkbox for "all files".

This is not rocket science.
  • Like
Reactions: PlayUltimate


macrumors 68030
Jan 19, 2015
Oregon, USA
Try select a single file with the .xls extension, do a get info, go to the "Open with:" section, select Excel in the drop down, click the "Change All..." button.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.