"You can’t open the application “Desktop” because it may be damaged or incomplete."

jsullivan2

macrumors newbie
Original poster
Jan 22, 2014
2
0
Whenever I try to drag something to the desktop it shows me the "no" symbol. If I drag it to the desktop folder in finder the "You can’t open the application “Desktop” because it may be damaged or incomplete." notification pops up.
Also, if I click on the Desktop folder in Finder, Terminal will pop up.

Does anyone know how I can fix this?


Also, if I were to reinstall the OSX:
1) How do I? lol
2) Would I lose any of my data?



Specs:
MacBook Pro
13 inch, Mid 2012
Processor - 2.9 GHz Intel Core i7
Memory - 8 GB 1600 MHz DDR3
Graphics - Intel HD Graphics 4000 1024 MB
Software - OS X 10.9.1 (13B42)
 

Nermal

Moderator
Staff member
Dec 7, 2002
18,681
1,183
New Zealand
If you can get to Disk Utility then try repairing permissions, although I'm not convinced that it'll help in this case. Worth a shot if you can get there though.

Edit: Terminal command is
Code:
open "/Applications/Utilities/Disk Utility.app"
 

jsullivan2

macrumors newbie
Original poster
Jan 22, 2014
2
0
If you can get to Disk Utility then try repairing permissions, although I'm not convinced that it'll help in this case. Worth a shot if you can get there though.

Edit: Terminal command is
Code:
open "/Applications/Utilities/Disk Utility.app"
Trying that now. What about the Repair Disk option?

EDIT: Repairing permissions didn't work.
 
Last edited:

Nermal

Moderator
Staff member
Dec 7, 2002
18,681
1,183
New Zealand
You could try Repair Disk if you haven't already, but if that doesn't work then it'd probably best to wait for someone more knowledgeable to reply.
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,179
8,829
California
Whenever I try to drag something to the desktop it shows me the "no" symbol. If I drag it to the desktop folder in finder the "You can’t open the application “Desktop” because it may be damaged or incomplete." notification pops up.
Also, if I click on the Desktop folder in Finder, Terminal will pop up.

Does anyone know how I can fix this?


Also, if I were to reinstall the OSX:
1) How do I? lol
2) Would I lose any of my data?
Have you been messing around in Terminal or doing anything you can think of that caused this? Maybe a new app or something you installed?

It would be very odd for this to just start all on its own.

Couple ideas. Make a backup first.

Hold command-r when booting to get to the recovery screen. While there, start Disk Utility and do a repair disk. Does that show any errors?

Stay in recovery and start Terminal from the Utilities menu. Type in resetpassword (all one word). Don't worry we are not changing your password.

You will get this screen. Click Macintosh HD at the top then select your user account from the drop down just below that. Leave the password fields blank, then click the reset button at the bottom right. That will reset all your user folder permissions back to default.

Then quit Terminal and restart.

If this does not work and you want to reinstall. Just command-r boot again and in that same screen click reinstall OS. That will download the OS and reinstall without erasing your data. You really should backup though just to be safe.

 

nyolc8

macrumors regular
Jul 20, 2012
205
1
Select "Desktop" folder in finder, then cmd+p to get folder properties info window, delete ".app" from the end of the filename. Then it will ask to remove the extension, click on remove extension.
 

jpete

macrumors newbie
Oct 26, 2017
12
7
07731
Before resetting or reinstalling or even logging into a guest account, try clearing cache folders. I'm currently on MacOS Sierra Version 10.12.6. Go > Go to > /var/folders > any folder except for zz (don't touch the zz folder), go into and clear any O, C, or T folders that you can. Empty your recycle bin and then restart. You should be able to open your apps again and see your app icons again. Twice this has happened to me - the first time, I went through all the possible fixes and then finally AppleCare supervisor figured it out by clearing a couple of Cache file folders. Second time it happened, they couldn't figure it out even with the record of the first fix - and figured it out myself despite the tech telling me I probably had a failing hard drive.