YouTube app takes a while to buffer

jgalan14

macrumors 6502
Original poster
Oct 11, 2011
458
0
So I been using on my iPhone a lot , love to watch videos like most people but I had problems with specially recently, when I start a video on YouTube (wifi ) it starts maybe a second later but half way or every 2 minute it pauses out of nowhere , I have to forward the video or start watching the video again, it happens on the iPhone app and the web browser too, It also happens on my iPad sometimes and idl what's wrong it or how to fix it I force close the app sometimes and the doesn't help all the time, I never had this problem on android phones ( I use many of them over a year) and it doesn't happen on 3G (it takes a bit to start the video but it never have problems buffering my wifi is between 10-20mbps and I don't have problems downloading apps or movies , or playing movies I don't even have the problem with Netflix, does anyone know the root cause ?
 

pilot1226

macrumors 6502a
Mar 18, 2010
595
13
USA
Could be the wifi connection, unless you're able to determine that this is happening from all wifi sources. Some Cable Companies are giving people a big speed bump at the beginning of big download files, which slowly tapers off. Wondering if the buffering is related to this somehow.
 

anonymous guy

macrumors 6502a
Mar 18, 2010
505
126
Use the m.youtube.com mobile site instead.

Videos buffer much quicker and the web interface is much nicer.
 

pilot1226

macrumors 6502a
Mar 18, 2010
595
13
USA
Use the m.youtube.com mobile site instead.

Videos buffer much quicker and the web interface is much nicer.
I will try this later, this is a brilliant suggestion. Sometimes we rely too much on apps and forget about simply using Safari to browse to the mobile site.
 

Applejuiced

macrumors Westmere
Apr 16, 2008
40,672
6,531
At the iPhone hacks section.
Tell me about it.
Im on a fast 30mbps wifi connection and a 2-3 minute video keeps freezing and pausing every few seconds.
Its been like that for years on the iphone youtube app. If I turn off wifi and play it with 3G it will load fine, even though grainy and worst quality. So I dont think its the internet cause my speed is very fast just the app. The mobile ios site runs great so I know its not youtubes servers either.
 

jgalan14

macrumors 6502
Original poster
Oct 11, 2011
458
0
Weird thing it happens on mobile site too I think I ma use 3G and the mobile site HD instead sucks that only happens on the phone and iPad, no problems on the laptop or ps3
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.