YouTube videos won't play---"This movie could not be played."

Discussion in 'iPhone' started by hikeNM, Feb 28, 2009.

  1. hikeNM macrumors 6502a

    Joined:
    Sep 29, 2004
    Location:
    Somewhere close to a dairy in East Texas
    #1
    Hello all. Got a problem.

    When I click on the YouTube application and choose a video to watch, I get an error message saying that "This movie could not be played."

    But when I go to the YouTube website through Safari, I can watch videos, although they're much grainier. Also, others with an iPhone can watch videos with the YouTube application. So it's not a problem with the network.

    There seems to be something wrong with the app.

    Anybody got any ideas.

    Thanks in advance.
     
  2. kas23 macrumors 603

    kas23

    Joined:
    Oct 28, 2007
    #2
    I have been getting this message A LOT over the past 3 days. Previous to this, I never had this problem. It has also been occurring on the wife's phone too, so must be a YouTube problem.
     
  3. hikeNM thread starter macrumors 6502a

    Joined:
    Sep 29, 2004
    Location:
    Somewhere close to a dairy in East Texas
    #3
    Very very interesting. My wife's phone seems to be normal. Her's is a 16 GB and mine is an 8. This is strange.
     
  4. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #4
    The iPhone plays YouTube videos in H.264 which is why they look a lot better than on the web site in Flash. You'll only get that message on videos that aren't also available in H.264.

    Example:
    On the iPhone go into YouTube > Search > type in "Apple Commercial"

    Play the first video (should be the 1984 commercial). It'll load.
     
  5. hikeNM thread starter macrumors 6502a

    Joined:
    Sep 29, 2004
    Location:
    Somewhere close to a dairy in East Texas
    #5
    Unfortunately, I've been getting the message on videos that have previously played. Something has changed.
     
  6. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #6
    Strange, works for me still. I've just tried several by random search. They all loaded quickly and played fine.
     
  7. hikeNM thread starter macrumors 6502a

    Joined:
    Sep 29, 2004
    Location:
    Somewhere close to a dairy in East Texas
    #7
    Hmm. Is there any way to search for H.264 videos only?
     
  8. Macman756 macrumors 6502a

    Macman756

    Joined:
    Sep 24, 2008
    Location:
    Atlanta, GA
    #8
    I don't think H.264 is the problem, I would watch a Youtube video, bookmark it, and come back to it. I played it fine about a week ago, just checked now, "THis Movie cannot be played" Something is going on.
     
  9. Four20 macrumors 6502a

    Four20

    Joined:
    Sep 22, 2007
    #9
    sadly there isn't. it's something that Apple asked Google/YouTube to do, and they convert the videos when they're able to. This is why you'll get this error on a lot of the brand new videos(they haven't had time to convert it yet).
     
  10. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #10
    From what I gather, anything on the non-iPhone YouTube site in High Quality is H.264. This link may explain further.
     
  11. hikeNM thread starter macrumors 6502a

    Joined:
    Sep 29, 2004
    Location:
    Somewhere close to a dairy in East Texas
    #11
    Yes. Same here.
     
  12. kdarling macrumors demi-god

    kdarling

    Joined:
    Jun 9, 2007
    Location:
    Cabin by a lake
    #12
    Hmm. Where does it reference H.264 in that article? Thanks!

    FWIW, people have been complaining in other forums lately. And I've got some favorites that won't play any more.
     
  13. Yves2 macrumors newbie

    Joined:
    Mar 1, 2009
    #13
    I recently uploaded a vacation video on youtube to share with friends. Showed it to many people on my Iphone. Two days ago I started receiving the message "this movie could not be played" (I am still able to watch certain clips but not others). Went to my account on Youtube and the video clip is fine. Not sure what to make of it...
     
  14. cherrybomb macrumors regular

    cherrybomb

    Joined:
    Feb 11, 2008
    #14
    I have this problem far too often. They need to work on providing a better application. I hardly use it, because it hardly ever works...
     
  15. hikeNM thread starter macrumors 6502a

    Joined:
    Sep 29, 2004
    Location:
    Somewhere close to a dairy in East Texas
    #15
    Well, I at least I'm not alone in this.
     

Share This Page