Zip Disc Will Not Eject...

Discussion in 'Macintosh Computers' started by Bob Dobbs, Nov 1, 2004.

  1. Bob Dobbs macrumors regular

    Jul 17, 2002
    OK G4 400Mhz AGP machine running OSX.3.5.

    I've got an factory installed Zip dirve in this machine and the disc will not eject. Paperclip does not work. The disc does not show up on the desktop, but System Profiler show the drive as there. The green light in on all the time (don't remember what that means).

    Any thoughts? Will I tear it up if I just pull with a pair of plyers?
  2. jsw Moderator emeritus


    Mar 16, 2004
    Andover, MA
    I would - at a minimum- shut down the system before trying the paper clip, on the off chance that powering down the system unmounts the disk and lets you eject it. Or power cycle once.
  3. combatcolin macrumors 68020


    Oct 24, 2004
    Northants, UK
    Can you take the entire Zip drive out and ply the disk from there?
    This should be able to give you a bit more leverage/wiggle room to work with.
  4. cubist macrumors 68020

    Jul 4, 2002
    Muncie, Indiana
    Agree, paperclip eject should be done with power off.

    If that doesn't work, there is a mechanical problem, and you'll probably need to replace the drive. IDE zip drives are around $10 or less used, so it's no big deal. It's easy to change, too - the G4 case is wonderfully easy to work with as long as you know how.
  5. Mechcozmo macrumors 603


    Jul 17, 2004
    The great Paper Clip would work if the computer is off. Also, try shaking the computer up and down a few times. That actually did work on an old classic Mac when the floppy got stuck. :D If the Paper Clip doesn't work then you need to pull open the drive. That's fun too... just kidding.
  6. Bob Dobbs thread starter macrumors regular

    Jul 17, 2002
    Paper Clip trick has been tried with comp on & off... no luck. I have not shaken the comp, but have jiggled the disc around endlessly... still no luck... bummer because I'm also trying to sell this thing, but dont want to leave the disc in there, guess I gotta pull the whole drive out...

    unless anyone else has other ideas????
  7. decksnap macrumors 68040


    Apr 11, 2003
    Jiggle the clip and keep trying- it's about catching the mechanism correctly. Since this is a manual solution, there is little reason why this wouldn't work. On some machines it is harder to catch it correctly, but unless it is locked up completely (don't know how it could) the clip shold work. Use more force!
  8. Miner Willy macrumors regular

    Apr 30, 2004
    Bradford, UK
    There could be an easier way...

    Restart the machine, as soon as you hear the start up chime hold down the mouse button - keep holding it down. This will eject all removable media, the cd drive will open first, then the zip. If this doesn't work then do the paperclip thing.

Share This Page