Zip file turns into IMG? (frustrated Switcher)

Discussion in 'Mac Apps and Mac App Store' started by luckyparadox, Jun 19, 2004.

  1. luckyparadox macrumors newbie

    May 15, 2004
    I'm really confused--I'm trying to download a zipped upgrade for my Netgear router...hoping that it would make the darn thing work. But when I download the zip file, it turns into a .img file that subsequently fails to mount ("no mountable file systems").

    Also, when I try to run the Help program from Finder, it crashes after two seconds.

    And my new router does not work with my powerbook--though my old one still does, and I can't get Roller Coaster Tycoon to work in VPC with Win2000, and a host of other problems that I really did not expect in making my switch from PC to Mac.

    I hate to say it, but I'm a really unsatisfied switcher (new PB 12") ... way too many compatibility/networking/printing/font issues...

    But if anybody can just help me figure out this zip file thing, so I can upgrade my Router, that would be great. One issue at a time...
  2. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    Have you repaired permissions?

    First, go to the Utilities folder within the Applications folder and launch Disk Utility. Then, click on the volume (Macintosh HD) and the First Aid tab. You'll see a button "Repair Permissions" most of the way down the dialog box. Click it and wait for it to complete.

    You may find that some of the issues simply go away.

    VPC is not meant to run 3D games. There is no virtual 3D hardware. I remember that Theme Park was sold for Macintosh. It may be possible that Roller Coaster Tycoon was available and that you could run it in the classic environment. (I know that you have the PC version, but if it means that much to you, you might buy the Macintosh version.)
  3. brap macrumors 68000

    May 10, 2004
    Sounds like you downloaded a corrupted file. Have you tried re-downloading it, or checking the filesize against that stated?
    ooh-er :confused:
    Well, I'm a fan of the tycoon games, and have run both Rollercoaster and Transport in Virtual PC in the past. What errors, specifically, do you get?
    -- as a side, Windows 98 is much better for gaming under VPC. Turn off virtual memory, and it runs like a charm. Win2k has too many overheads...
    Sad to hear that. You have to expect some teething troubles, though. Stick with it, and go for one issue at a time. I usually find they're solutions staring me in the face :eek:
  4. brap macrumors 68000

    May 10, 2004
    The (real) Tycoon series all run in 2d, 256-colour mode. I ran them on a win95 Pentium-S 120 back in the day, but to my knowledge there never was a Macintosh port. Anyway, Virtual PC Whips it, in the Devo sense..
  5. Thirteenva macrumors 6502a

    Jul 18, 2002
    I may be able to help

    1) What model powerbook? is it airport Extreme Card(802.11g) or Airport Card(802.11b)

    2)That img file will not mount. In the newer netgear routers that is the file you upload to the router to update the firmware.

    3)VPC is awful for games, i've tried running Roller Coaster tycoon in it and its awfully slow (i have a 1ghz powerbook)

    4) font/network/printing issues? If you start a new thread for those we'll be happy to help you :).

    Don't get discouraged. It's like moving to a new neighborhood, when you first get there you don't know where anything is and feel lost. After a little while its feels like home.
  6. Thirteenva macrumors 6502a

    Jul 18, 2002
    There is no mac port of RCT. And i'm told their won't be. I also like this game.
  7. 7on macrumors 601


    Nov 9, 2003
    Dress Rosa
    Help viewer crashing.

    Delete the ~/Library/Preferences/

    Delete ~/Library/Caches/

    See if that helps.
  8. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    I remember doing something like that, using the router utilities within the router to upload the file to the router.

    The router will recognize the file, but the OS doesn't.
  9. luckyparadox thread starter macrumors newbie

    May 15, 2004
    Oh man you are a genius! I had to delete as well--what did I do, and why did it work?!

    Thank you!

    One down, a few more to go...still no luck with the router....I've tried all the above. And I've given up on RCT (anybody know any good Mac replacemtent? I don't like the turn-based format of Civilization. I'm thinking SimCity might be as enjoyable as RCT. Any suggestions?)
  10. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    All you did was delete the HelpViewer preferences file (, HelpViewer's temporary data cache ( folder), and one of the two global help preference files (; the other one is These files/folders are the ones that can cause HelpViewer to crash if they become corrupted. Deleting them tells HelpViewer to make new ones - problem solved!
  11. luckyparadox thread starter macrumors newbie

    May 15, 2004
    Awesome. I finally got a response from Netgear and they got my router working. So All is Well in Macland.

    Thanks everyone for the help.

Share This Page