PDA

View Full Version : open firmware problem installing to g4 imac




inscrewtable
Oct 9, 2010, 05:53 AM
I have searched the web and tried suggested pram reset but it did not work. I am trying to load up tiger onto a 15" g4 800MHz imac. I have tried a few different ways to install but it keeps giving me the open firmware screen after I hear it searching for the DVD to boot from. The DVD loads on the desktop OK and I can click the 'install' button where it then tries to restart, and I have also set the startup disk to start up from osx on the dvd but both won't work.

I have checked on the apple support site and it appears that this model does not need a firmware update. I did read somewhere that a security update could cause these sorts of issues but I don't know if that is the case here.

Is there anything else anyone may suggest I try?

I don't know if this is relevant but there is one 512mb ram module in one of the slots and one slot is empty



boogers
Oct 9, 2010, 04:00 PM
Check the disc integrity. The first set of blocks should be either hfs or hfs+ with a boot loader.
I'm speaking from Linux/BSD experience but this next part may help.
If possible, try formatting a usb key with the first partition being hfs for the boot loader- mac-fdisk is what I used don't know the MacOS equivalent- with the install being on a fat32 partition.

If you're not sure, then research before you commit.