PDA

View Full Version : My Powerbook hates Wireless Networks


mainstreetmark
Jan 12, 2005, 03:03 PM
Yeah, another "My wireless network has problems" thread. Sorry.

Alright, so at home, about 10 feet above my head (through a floor), sits an Airport Express plugged into the cable modem. I get 80%+ signal.

At work, a Linksys is about 4 feet behind me (through a wall). I get 100% signal.

At work AND at home, I got about 20% packetloss on a ping of google.com.

At home, I can ping the Airport Express for hours with 0% packet loss.

At work, my wireless network connection drops frequently. At home, it used to but hasn't in a while.

It actually dropped while posting this message. Here's syslog:

Jan 12 15:00:50 localhost kernel: AirPort: Link DOWN
Jan 12 15:01:33 localhost kernel: AirPort: Link DOWN (out-of-range)
Jan 12 15:01:36 localhost kernel: AirPort: Link UP: "*****" - 0012176d3ab6 - chan 11

I am using interface robustness.

What's going on here? I never used to have problems.

Is there a log I can look at? Should i be paying attention to tcpdump?

Gee
Jan 12, 2005, 03:47 PM
Try changing channels on your wireless boxes - might just be that you're getting interference fro your neighbor's microwave....

northen
Jan 12, 2005, 03:51 PM
Well, depending on the country you live in, you should, like the previous poster stated, change the channel.

I live in Europe, so I use channel 11. The problem is that the ISM band (International Scientific and Medical) around 2.4-2.5 GHz is license-free, so many different devices will overlap the band, including cordless phones and similar, but they typically use different channels than the WiFi hardware :)

honeytoast
Jan 12, 2005, 03:53 PM
did you turn on interference robustness on because of problems you have had before? That option can really kill your range.

mainstreetmark
Jan 13, 2005, 11:40 AM
Well, like I said, I doubt it's anything to do with range - I'm right next to the wireless devices in each case.

Here's some new info:
- The Win2k server i have right next to me is iTunesing my music, but it keeps having to resync about once every 3 songs. I try to ping it and am getting 10-30% packet loss. Pinging the Airport Express is 0% packet loss. The Win2k server is also wireless.

hulugu
Jan 13, 2005, 11:56 AM
Well, like I said, I doubt it's anything to do with range - I'm right next to the wireless devices in each case.

Here's some new info:
- The Win2k server i have right next to me is iTunesing my music, but it keeps having to resync about once every 3 songs. I try to ping it and am getting 10-30% packet loss. Pinging the Airport Express is 0% packet loss. The Win2k server is also wireless.

Odd problem that I had with the Airport Express streaming music is using the 802.11b/g option with my Powerbook; so I changed the AE to 802.11b only and it works great.

mainstreetmark
Jan 17, 2005, 04:08 PM
Yeah, the "All-802.11B" network seemed to fix my stream re-buffering problem.

The dropping off at work problem I'm just going to blame on the network here. A tcpdump -i en1 shows tons, and tons, of "arp who-has" messages. 7.5KB/s worth!!

mainstreetmark
Jan 18, 2005, 11:26 AM
New "At Home" problem. Sheesh.

Ok, so eeevery so often at home, i drop off the Airport Express wireless. My tcpdump says this:

11:24:09.996960 IP 10.0.1.4.mdns > 224.0.0.251.mdns: 0*- [0q] 1/0/0 (263)
11:24:10.710683 mark.local > ff02::fb: HBH icmp6: multicast listener report max resp delay: 0 addr: ff02::fb [hlim 1]
11:24:10.712395 mark.local > ff02::2: HBH icmp6: multicast listener done max resp delay: 0 addr: ff02::1:fff2:8569 [hlim 1]


Seems to be a lot of unusual stuff in there. Idears?