PDA

View Full Version : iPod photo Software Update -- Broken _show_voltage?




ChrisBrightwell
Mar 30, 2005, 10:52 AM
Hi Everyone,

I've been using the _show_voltage hack on my iPods from the beginning, first on a 3G 20GB and now on a 60GB photo.

Since updating this iPod to v1.1, though, the _show_voltage hack has stopped working. The file is there, but it's like the iPod just doesn't give a damn.

I haven't tried formatting and restoring the iPod. I might do that tonight. Any other suggestions? Am I the only one seeing this?

Thanks.



ChrisBrightwell
Mar 31, 2005, 12:24 AM
OK ... restoring the iPod Software didn't do the trick.

Any ideas, anyone?

ChrisBrightwell
Mar 31, 2005, 11:17 AM
Oh, come on.

I *know* I'm not the only person w/ a 60GB iPod photo using the latest version of the iPod Software.

clayj
Mar 31, 2005, 11:43 AM
You're not the only one. But I know not of this "_show_voltage" hack of which you speak, and I ain't gonna be hackin' my iPod anytime soon. :)

ChrisBrightwell
Mar 31, 2005, 11:45 AM
Here's more info on the hack:
http://www.macosxhints.com/article.php?story=20040226061632743

pdpfilms
Mar 31, 2005, 12:11 PM
clayjohanson
You're not the only one. But I know not of this "_show_voltage" hack of which you speak, and I ain't gonna be hackin' my iPod anytime soon.

I'm with you. An iPod is like a fine piece of art... I sure as hell wouldn't draw in a smile on the Mona Lisa.

ChrisBrightwell
Mar 31, 2005, 12:46 PM
Hey, it's not like I'm cracking open the iPod and installing some sort of voltmeter or something. It's a simple software hack that changes the appearance of the battery meter to something infinitely more useful.

clayj
Mar 31, 2005, 01:02 PM
Hey, it's not like I'm cracking open the iPod and installing some sort of voltmeter or something. It's a simple software hack that changes the appearance of the battery meter to something infinitely more useful.Except it apparently doesn't work anymore. :) (Sorry, I'm still not trying it, especially if I don't think it's actually going to work.)

ChrisBrightwell
Mar 31, 2005, 01:05 PM
Except it apparently doesn't work anymore. :) I'm trying to determine if this problem is unique to my iPod. The fact that no one can help confirm or deny that they're having the same problem I am does little more than frustrate me.

(Sorry, I'm still not trying it, especially if I don't think it's actually going to work.)Suit yourself. There's no harm to be done whatsoever, but suit yourself.

clayj
Mar 31, 2005, 01:36 PM
OK, riddle me this, and I'll try it: How do you UNDO the _show_voltage hack once you've enabled it? (I'm looking for the Terminal command line here.) I like my battery meter and I want to be able to switch straight back to it once I've tested the hack.

ChrisBrightwell
Mar 31, 2005, 01:47 PM
To introduce the hack:
touch /Volumes/Your_iPod_Name/iPod_Control/Device/_show_voltage

To remove the hack:
rm /Volumes/Your_iPod_Name/iPod_Control/Device/_show_voltage

"touch" creates the file, "rm" removes it.

Thanks.

clayj
Mar 31, 2005, 01:58 PM
OK, I ran the command line in Terminal, ejected, disconnected, and restarted iPod. Still got a battery meter, so I'm assuming it doesn't work anymore.

ChrisBrightwell
Mar 31, 2005, 02:09 PM
... Interesting.

Thanks.