PDA

View Full Version : i'm stuck! can't restore on admin-locked-down MBA, no password




dave22r
Oct 15, 2011, 11:43 AM
bought an 11 inch macbook air yesterday, the mom locked down kid's account and forgot her password. so the only access i have to the system is on an account that i can't get into the system preferences or really do anything.

so my question- how do i restore this thing?

i have an external dvd. stuck a snow leopard dvd in there, restarted, held C, then tried D, tapped C, tapped D, then held or tapped the other 24 letters in the alphabet. i can't get to disk utility. not sure where to go next...



dangerfish
Oct 15, 2011, 12:00 PM
Can't You do Lion Internet recovery?

dave22r
Oct 15, 2011, 12:08 PM
it's an older version of snow leopard, no app store, no lion.

dangerfish
Oct 17, 2011, 01:51 PM
But doesn't the MBA have Lion? You should be able to do Restart and then CMD + R to enable internet recover.

Nermal
Oct 17, 2011, 02:01 PM
What happens if you reboot while holding Option?

Consultant
Oct 17, 2011, 02:07 PM
Don't buy computers without user account credential.

You might be buying something stolen.

electrolux76
Oct 17, 2011, 02:48 PM
Ok, here's one way to take care of this:

Get your hands on a Snow Leopard instal disk. Hopefully one came with the computer you bought. If no,t borrow one, grab one off ebay of by any other means.

Find a USB optical drive. Boot from the DVD by connecting the optical drive, inserting disk and booting the MBA while holding down the C key.
Once booted, as soon as you get to a step in the process where you see a menu bar at the top of the screen, you can select "Utilities" and there should be a password reset function there.

Also, getting a Snow Leopard DVD and a usb optical drive is kinda a pain in the ass so maybe the 1st thing you should do is contact an apple store and see if they can just take care of it for you. It really only takes a few minutes.

dave22r
Oct 17, 2011, 07:56 PM
I have a snow leopard DVD and an external drive. Booted holding C with it plugged in, unplugged, no dice. Just tried holding command. Then command C just for the fun of it.

Every time I did any of this it goes straight to the login screen. Still scratching my head!!

Robo6675
Oct 17, 2011, 08:01 PM
What about booting from a USB drive? Then you could access the internal drive and be able to reinstall from the DVD.

That is assuming you have a USB drive that is a clone of a system drive you can access the admin stuff on.

Robo6675
Oct 17, 2011, 08:03 PM
Isn't "option" the key to hold down to boot from another drive, not "c"?

dave22r
Oct 17, 2011, 11:27 PM
C is to boot from a CD. neither that or option yielding any results. i'm making a lion USB flash drive now. had to find the one system in my house w/o lion on it and is eligible for the download and it's in work!!!

hoping that will work :)

dave22r
Oct 18, 2011, 10:00 AM
And it didn't work :(

tardman91
Oct 18, 2011, 11:33 AM
Buy a new HD and start from scratch?

Kaylor
Oct 19, 2011, 12:08 AM
if this is a rev. E (sandy bridge 2011) macbook air it can't run snow leopard.

jdechko
Oct 19, 2011, 11:33 AM
Try this: http://osxdaily.com/2010/08/10/forgot-mac-password-how-to-reset-mac-password/

dave22r
Oct 20, 2011, 02:50 PM
Isn't "option" the key to hold down to boot from another drive, not "c"?
Yeah, that one brings up a picture of a lock and a block for a password. Apple said that one would work.

Try this: http://osxdaily.com/2010/08/10/forgot-mac-password-how-to-reset-mac-password/

Tried it. Not having much luck here...

scenemissing
Oct 20, 2011, 08:00 PM
Did you say it has Parental controls on it or a firmware PW?

abz1981
Oct 22, 2011, 12:33 PM
think its best taking it to an Apple store to be honest. get a genius to fix this issue.

xraydoc
Oct 24, 2011, 08:47 PM
Sounds like the firmware password is set.
You'll need to Google how to bypass that.

Edit: if you can. The only ways I know require the battery and RAM to come out. Removing the RAM is obviously a problem in the MBA.

jdechko
Oct 25, 2011, 12:35 PM
https://support.apple.com/kb/ts2391

If you cannot remember the EFI firmware password for your MacBook Air, please schedule a service appointment with either an Apple Retail Store or an Apple Authorized Service Provider.

Looks like that the only way to get around it is to get Apple to do it.

Yentinglin
Oct 27, 2011, 02:51 AM
I got my 2011 mac air for about 1 month and I forgot my admin password,
and I found this website would help:

http://iphone5jailbreaktips.com/how-to-reset-the-admin-password-in-mac-os-x-lion.html

I tried method 1 and i t worked for me.
No disk, just restart, enter recovery mode and use the terminal!

frankieboy
Oct 27, 2011, 11:17 PM
The OP states he is running Snow Leopard in his second post, not Lion as the article you reference requires.

... I found this website would help:

http://iphone5jailbreaktips.com/how-to-reset-the-admin-password-in-mac-os-x-lion.html