PDA

View Full Version : Blue pinwheel javascript cursor?


mcdj
Nov 6, 2011, 01:46 AM
Has something changed at MR? All of a sudden I'm getting a spinning blue pinwheel for "cursor: wait" when MR pages are loading in Safari. I've never seen it here before. It's either something's changed on the MR side, or it's Lion.

http://www.w3schools.com/cssref/playit.asp?filename=playcss_cursor&preval=wait

EvanLugh
Nov 6, 2011, 09:09 AM
i believe it depends which browser you're using. For example in chrome, i get the watch. There was an article somewhere about websites setting it for certain browsers. I think safari has always had it, though?

Let's Sekuhara!
Jul 10, 2012, 12:36 AM
Has something changed at MR? All of a sudden I'm getting a spinning blue pinwheel for "cursor: wait" when MR pages are loading in Safari. I've never seen it here before. It's either something's changed on the MR side, or it's Lion.

http://www.w3schools.com/cssref/playit.asp?filename=playcss_cursor&preval=wait

By "MR" I presume you are talking about the Japanese region-specific build of OS X 10.8 ..."Mountain Rion"

Right?
No?
Not so much?
...ok, fine. I will disappear back into teh shadowz of teh interwebz from whence I came. And take my cheesy jokes with me. :rolleyes:

Comeagain?
Jul 10, 2012, 12:52 AM
By "MR" I presume you are talking about the Japanese region-specific build of OS X 10.8 ..."Mountain Rion"

Right?
No?
Not so much?
...ok, fine. I will disappear back into teh shadowz of teh interwebz from whence I came. And take my cheesy jokes with me. :rolleyes:

Terrible joke you mean. We all refer to MacRumors as MR. Because we're lazy like that.

I get the Blue pin wheel sometimes on lots of different websites. Nothing specific to Macrumors.

WilliamG
Jan 22, 2013, 05:41 AM
I just started today getting the blue pinwheel javascript ball on Macrumors. Happening an awful lot. Any ideas, people?

2012 iMac, 10.8.2, using Safari.

arn
Jan 22, 2013, 01:15 PM
I just started today getting the blue pinwheel javascript ball on Macrumors. Happening an awful lot. Any ideas, people?

2012 iMac, 10.8.2, using Safari.

We made the site a little more Javascript intensive. But not massively so. We are lazy loading more items. So after the main page is displayed, Javascript loads additional items. The overall goal is to make the initial usable load faster, while later loading other items via Javascript.

I'm not sure why you'd be getting slow-downs more than others though, esp with modern hardware.

arn

WilliamG
Jan 22, 2013, 02:47 PM
We made the site a little more Javascript intensive. But not massively so. We are lazy loading more items. So after the main page is displayed, Javascript loads additional items. The overall goal is to make the initial usable load faster, while later loading other items via Javascript.

I'm not sure why you'd be getting slow-downs more than others though, esp with modern hardware.

arn

I'm not getting any "noticeable" slowdowns, that I can tell. I just really don't like seeing the pinwheel all the time. It's not actually affecting anything except drawing my attention to the cursor, because it looks like something bad is happening! Spinning wheels = bad!

And yes, I'm not thrilled to be using Macrumors right now, that's for sure. :(

Weaselboy
Jan 22, 2013, 03:28 PM
I just started today getting the blue pinwheel javascript ball on Macrumors. Happening an awful lot. Any ideas, people?

2012 iMac, 10.8.2, using Safari.

Odd you see it and I don't at all. 2012 13" MBA on 10.8.2 with Safari. :confused:

WilliamG
Jan 22, 2013, 03:33 PM
Odd you see it and I don't at all. 2012 13" MBA on 10.8.2 with Safari. :confused:

Yep not sure what the dealio is. I'm curious as to what changed on the site in the last 24-or-so hours. Hopefully arn can reply again and say if the changes happened then or if it's something else.

Interestingly, later today I haven't seen any blue pinwheels on Macrumors...

(now watch it happen about 5 minutes after I post this!)

SandboxGeneral
Jan 22, 2013, 03:34 PM
We made the site a little more Javascript intensive. But not massively so. We are lazy loading more items. So after the main page is displayed, Javascript loads additional items. The overall goal is to make the initial usable load faster, while later loading other items via Javascript.

I'm not sure why you'd be getting slow-downs more than others though, esp with modern hardware.

arn

I'm not getting any blue pinwheels and the site is working fine for me. However I did notice that the formatting of the site is wider now. I only noticed because I had to adjust the width of my browser because it was getting cut off, where it wasn't a day or two ago.

GGJstudios
Jan 22, 2013, 03:40 PM
I'm not getting any blue pinwheels and the site is working fine for me. However I did notice that the formatting of the site is wider now. I only noticed because I had to adjust the width of my browser because it was getting cut off, where it wasn't a day or two ago.
Zero beachballs here, but I noticed the wider format as well. I'd prefer it narrower, but it's not a huge deal.

arn
Jan 22, 2013, 09:57 PM
I'm not getting any blue pinwheels and the site is working fine for me. However I did notice that the formatting of the site is wider now. I only noticed because I had to adjust the width of my browser because it was getting cut off, where it wasn't a day or two ago.

Zero beachballs here, but I noticed the wider format as well. I'd prefer it narrower, but it's not a huge deal.

We talking about the forums or the front page?

arn

arn
Jan 22, 2013, 10:20 PM
We talking about the forums or the front page?

arn

nevermind, I fixed it.

arn

----------

Yep not sure what the dealio is. I'm curious as to what changed on the site in the last 24-or-so hours. Hopefully arn can reply again and say if the changes happened then or if it's something else.

Interestingly, later today I haven't seen any blue pinwheels on Macrumors...

(now watch it happen about 5 minutes after I post this!)

I already said: http://forums.macrumors.com/showpost.php?p=16706054&postcount=6

arn

WilliamG
Jan 23, 2013, 05:33 AM
nevermind, I fixed it.

arn

----------



I already said: http://forums.macrumors.com/showpost.php?p=16706054&postcount=6

arn


Yes, you already said. But I was curious as to the timing. Was it in the last 48 hours, or was it a week or two ago that you made the site more java-intensive? I'm just trying to narrow down exactly when you made those changes. :)

arn
Jan 23, 2013, 10:00 AM
Yes, you already said. But I was curious as to the timing. Was it in the last 48 hours, or was it a week or two ago that you made the site more java-intensive? I'm just trying to narrow down exactly when you made those changes. :)

Yep, just on Monday.

arn

WilliamG
Jan 23, 2013, 12:06 PM
Yep, just on Monday.

arn

OK cheers for the update. I'll have to see how it goes. Didn't see any more pinwheels after I posted. Did you change anything since the change?! :D

arn
Jan 23, 2013, 02:09 PM
OK cheers for the update. I'll have to see how it goes. Didn't see any more pinwheels after I posted. Did you change anything since the change?!:D

Nope, haven't changed the JavaScript.

arn

WilliamG
Jan 23, 2013, 03:41 PM
Nope, haven't changed the JavaScript.

arn

Very bizarre. Well thanks for the replies. Just have to hope the blue stays away!