PDA

View Full Version : Working External HD Not Showing Files in Finder




rubaflo
Nov 29, 2011, 04:03 AM
Computer
MBA 13" (4 GB RAM & 1.86 processor)
OS X Lion 10.7.2

Hard Drive
WD My Passport 500 GB
NTFS Formatted

Everything has been working fine with this hard drive for several weeks. Last night Adobe Lightroom 3 froze while closing and I had to force quit. Lightroom is reading both the catalog and images from the external HD. Since then when I put the HD in it shows up in the Finder but no folders appear. The finder CPU usage ramps up and makes the laptop almost unusable. I've literally spent the majority of an entire day researching and trying different things with no luck. I've tried:


Disk Utility - no luck as it can't unmount the drive
Confirmed HD is still working by using on another PC laptop
Confirmed MBA still works by accessing a separate WD External HD
Relaunching finder both with and without HD connected
Looked for anything weird in Activity Monitor (not seeing anything)
lsof /volumes to look for open files
Downloaded xFile and was able to access the files within the HD (albeit the computer was horribly slow)
Can only eject the disk by choosing the "Force Eject" option and then waiting a couple minutes for it to work


One weird thing I noticed is that when trying to launch Lightroom again I had the option to load with the same catalog (file) previously used on the external HD and I got an error message that it was already open. However, nothing else was open and Activity Monitor isn't showing any Lightroom activity. This was leading me to believe that the Finder (or laptop) was trying to access a LR catalog file perhaps?

Note that this is my first Apple product and I'm not exactly tech-savvy but can follow directions well and try to figure things out on my own. Any help would be MOST appreciated as the only other thing I can think of is a clean Lion install (problem since I've already upgraded and didn't save the installer file).

I also clicked on "Inspect" in Activity Monitor for the Finder. Then ran a sample and have attached the output as a text file since it looked kind of long to place in the actual post.

Thanks!



ToeKNife99
Nov 30, 2011, 08:15 PM
This is odd, but I am having a similar issue. I have a second internal 500GB OS X formatted HDD in my MPB 2011. For the last couple of days I am unable to view files and folders on the drive. Some folders work fine but others show nothing but when you search the folder they show or if you drag and drop the folder on to iTunes the files work. The files are there they just don't show....

Is this a Lion bug? Is it possible to re-index the drive?

----------

Just like in Windows, when in doubt reboot! Seems to have come back to life!

Partron22
Nov 30, 2011, 11:14 PM
Is this a Lion bug?
Worse in 10.7.2, it seems.

There's been a steady stream of reports like yours since it came out.
eg
http://forums.macrumors.com/showthread.php?t=1281572
http://forums.macrumors.com/showthread.php?t=1266724
http://forums.macrumors.com/showthread.php?t=1266070
http://forums.macrumors.com/showthread.php?p=13745220