PDA

View Full Version : Messages Badge Issue




GaresTaylan
Feb 20, 2012, 06:35 AM
Hey everyone. On Messages, Ive encountered an issue where the icon in the dock shows I have 1 unread message. Thing is, I have no open messages. Im not sure if I closed one without clicking on it first or what.

From what Ive noticed, if I have say, 4 unread messages and I open the app up, then click on the message window containing those 4 unread messages... it will drop the number on the badge. If I click out of messages, the number goes back up. Its like its not permanently marking them as read when I click that message box.

Any ideas???



almostaskater62
Feb 20, 2012, 01:07 PM
happening to me too...it's very annoying

JangoFett124
Feb 20, 2012, 01:17 PM
You should file a bug report with Apple.

satkin2
Feb 20, 2012, 02:04 PM
You should file a bug report with Apple.

Where? I can't see a feedback option either in the messages app, or on Apples feedback page. The messages beta page didn't help much either.

JangoFett124
Feb 20, 2012, 02:15 PM
http://bugreport.apple.com

satkin2
Feb 20, 2012, 02:24 PM
http://bugreport.apple.com

Thanks

vtstarck
Apr 25, 2012, 12:24 PM
Anyone else noticing the badge counts are much better recently?

JohnDoe98
Apr 25, 2012, 03:56 PM
Anyone else noticing the badge counts are much better recently?

My badges are displaying double the actual number of messages. It's been very annoying lately.

Watabou
Apr 26, 2012, 12:21 AM
This has been happening to me too recently (on Lion).

I found a sort of a temporary fix though: Open up Terminal and type: "killall Dock" without the quotes and that fixes the problem for me.

3bs
Jul 28, 2012, 03:28 PM
This has been happening to me too recently (on Lion).

I found a sort of a temporary fix though: Open up Terminal and type: "killall Dock" without the quotes and that fixes the problem for me.

That does fix it but it's annoying having to keep doing it and it happens several times a day to me.

Watabou
Jul 28, 2012, 03:44 PM
Are you running Lion? I think the Messages app in Mountain Lion fixes the problem. I don't have this problem anymore.

3bs
Jul 28, 2012, 03:57 PM
Are you running Lion? I think the Messages app in Mountain Lion fixes the problem. I don't have this problem anymore.

It happened to me in Lion and now also in Mountain Lion. I did an upgrade, not a clean install so that might be the issue but Apple shouldn't expect everyone to be doing a clean install anyway.

bushido
Jul 28, 2012, 04:02 PM
used to happen to me on Lion but ML has a new iMessages built and works just fine so far