PDA

View Full Version : Songs under album, not artist




07dodge
Jun 10, 2012, 01:34 PM
So I have a 120Gb iPod Classic from about 2008, works flawlessly. Only issue I have is some artists don't appear under the "Artists" section, but are in the "Albums" section. I don't find music by what album the song is on (I can't remember what song is on which album) so it's all by the artist.

Anyone know how to remedy this problem?



kaielement
Jun 10, 2012, 02:42 PM
This has to do with the way the songs are tagged in iTunes only way to fix it is go back into iTunes and make sure that the artist names are not in the album info other then that if that don't work files must be corrupt

07dodge
Jun 13, 2012, 03:50 PM
How would I determine files are corrupt?

As an aside, anyone ever had songs only download half way, maybe a bit more? I have a couple songs loaded on the iPod that cut off early

kaielement
Jun 14, 2012, 08:07 PM
If my suggestion didn't work then you will know they are corrupt and if this is so YOu could try to del eat the songs and reload them. But I suspect that it's a tagging issue. This happens to me sometimes like I might set an album to compilation on accident then it won't show up under that artist but will show up in the compilations. But that's an easy fix like I said. Any other questions let me know

07dodge
Jun 15, 2012, 11:09 PM
I'v gone through almost all of them, and doesn't seem like I have them mislabeled. I'll try to reload them, maybe that's all it is. Thanks!