PDA

View Full Version : Mountain Lion Password Enter Lag




Sid-R
Aug 1, 2012, 11:47 AM
Since I updated to ML.. whenever I open the lid to wake my MBA from sleep.. The screen comes up pretty quick but when I type nothing registers for quite a few seconds and then after a lag period of a few seconds I am able to type my password... This was never the case before.
Anyone else experiencing this?



eric/
Aug 1, 2012, 12:08 PM
Since I updated to ML.. whenever I open the lid to wake my MBA from sleep.. The screen comes up pretty quick but when I type nothing registers for quite a few seconds and then after a lag period of a few seconds I am able to type my password... This was never the case before.
Anyone else experiencing this?

Yes. I think it's due to the amount of time that the MBA has been inactive. I think it takes a second to restore complete functionality from sleep. So far for me, if I close the lid and then open it within a few minutes I don't experience the lag.

b-rad g
Aug 1, 2012, 02:00 PM
Yes definitely experiencing this! Thought ML was going to make my Air more "Instant On" like it was in Snow Leopard and the screen does come up fast, but the lag to put in password just ruins it.

wayne905
Aug 1, 2012, 02:05 PM
Yes definitely experiencing this! Thought ML was going to make my Air more "Instant On" like it was in Snow Leopard and the screen does come up fast, but the lag to put in password just ruins it.

I noticed the same lag on my MacBook Air too :-(

MTC2HHK
Aug 1, 2012, 02:26 PM
Installed ML on MBP, experienced significant lag as discussed... ran the repair feature in disk utility and everything is zippy again.

sanityinc
Aug 1, 2012, 02:40 PM
After 4200 seconds (1 hour and 10 minutes) of sleeping, the MBA silently hibernates itself to conserve battery power. Waking up from hibernation takes a few seconds, whereas waking from sleep is almost instantaneous.

You can change that period with a little techie know-how, but I wouldn't suggest doing so, because it's a reasonable default.

Perhaps knowing the reason for the delay will help give you the patience to wait those few seconds. :-)

b-rad g
Aug 1, 2012, 02:43 PM
Installed ML on MBP, experienced significant lag as discussed... ran the repair feature in disk utility and everything is zippy again.

After you did this, how many seconds from the time your screen turns on and the time you can actually enter your password? Can you enter your password immediately?

Beanoir
Aug 1, 2012, 04:39 PM
i'm also having the same issue. It's not a big issue I admit, but would be nice if it wasn't like it!

MTC2HHK
Aug 1, 2012, 05:30 PM
After you did this, how many seconds from the time your screen turns on and the time you can actually enter your password? Can you enter your password immediately?

Instantly... I cannot see any lag or delay from the time I open the screen and typing has zero delay, zero delay after password is entered... after I ran the repair tool in disk utility. Try to run verify disk and then repair if needed... worked for me.

Something in the ML installation caused problems with the disk and slowed things way down... after running repair it was much faster.

asting
Aug 1, 2012, 05:46 PM
I noticed this too, and just disabled Power Nap. It seems to have disappeared, but I only have one instance of starting it up to use as my benchmark (meaning I only let it sleep a few hours one time so far).

buddybd
Aug 1, 2012, 06:43 PM
I have the same problem but there's no lag if the MBA is connected to the power socket. Power Nap enabled but not on battery (if that makes a difference).

Repairing disk permissions, hopefully that'll work. Thanks none the less :)

b-rad g
Aug 1, 2012, 06:48 PM
Instantly... I cannot see any lag or delay from the time I open the screen and typing has zero delay, zero delay after password is entered... after I ran the repair tool in disk utility. Try to run verify disk and then repair if needed... worked for me.

Something in the ML installation caused problems with the disk and slowed things way down... after running repair it was much faster.

I have repaired and still have the lag.

mathcolo
Aug 1, 2012, 07:10 PM
I have repaired and still have the lag.

Did you repair disk permissions in addition to the standard "Repair Disk"?

b-rad g
Aug 1, 2012, 07:58 PM
Did you repair disk permissions in addition to the standard "Repair Disk"?

Couldn't repair disk cause after it verified "Repair Disk" was greyed out. Do I need to repair it from the recovery partition disk utility?

spawnfreak
Aug 1, 2012, 09:04 PM
Computer -> Macintosh HD -> Library -> Cache {delete all files inside cache folder}

Then right click on trash bin and press Command, click SECURE EMPTY TRASH

----

Report back if you see some improvement

sanityinc
Aug 2, 2012, 02:44 AM
There's no connection with PowerNap. Even with it disabled, the default behavior is as I described above.

macography.net
Aug 2, 2012, 03:57 AM
Yes, I've noticed this too.

sanityinc
Aug 2, 2012, 06:35 AM
There's a lot of voodoo being invoked here. Before those affected go clearing their caches and repairing permissions - only to find that the delay persists when their computers sleep for longer periods - please take a moment to read the information I posted above.

b-rad g
Aug 2, 2012, 06:55 AM
There's a lot of voodoo being invoked here. Before those affected go clearing their caches and repairing permissions - only to find that the delay persists when their computers sleep for longer periods - please take a moment to read the information I posted above.

Yes after I cleaned the cache and repaired the disk from disk utility I still get the lag when it has been asleep for more than an hour. I know it's the hibernate mode that is causing this, but it didn't happen under Snow Leopard so why must it happen now and under Lion?

sanityinc
Aug 2, 2012, 07:38 AM
Yes after I cleaned the cache and repaired the disk from disk utility I still get the lag when it has been asleep for more than an hour. I know it's the hibernate mode that is causing this, but it didn't happen under Snow Leopard so why must it happen now and under Lion?

Lion added the "Standby" feature, whereby the computer switches from sleep to hibernation after a predefined period. (I believe the feature is not supported on all hardware -- it certainly wasn't on my early unibody MBP. That machine had a user-replaceable battery, so removing the battery during standby sleep would leave the computer no chance to create a hibernation file.)

The default behavior in Snow Leopard - or when the hardware does not support Standby - is to create the hibernation file at sleep time and then keep sleeping until the battery gets critically low.

Wowzera
Aug 3, 2012, 07:35 AM
has anyone found a solution yet? I've this problem aswell.

Acorn
Aug 3, 2012, 08:48 AM
ive noticed this as well. i open the lid then type my password and it fails because half the password wasnt typed because of the delay. its not that big a deal but annoying none the less.

madsci954
Aug 3, 2012, 09:19 AM
I was seeing this same issue on my 2011 MBA when it was running Lion. It would sometimes take a second or 2 to wake then another second or 2 before I can type.

But since updating to ML, the problem is gone. Whether is was sleeping for 5 minutes or overnight, it boots up instantly and there is no type lag.

Wowzera
Aug 3, 2012, 02:18 PM
I was seeing this same issue on my 2011 MBA when it was running Lion. It would sometimes take a second or 2 to wake then another second or 2 before I can type.

But since updating to ML, the problem is gone. Whether is was sleeping for 5 minutes or overnight, it boots up instantly and there is no type lag.

Mine was like this in Lion. Since upgrading to ML I'm with that issue. I don't remember if it started to happen after installing the powernap firmware upgrade.

madsci954
Aug 3, 2012, 02:34 PM
I don't remember if it started to happen after installing the powernap firmware upgrade.

I have the Powernap update installed, but I'm not sure if this affected performance or not, as I installed it as soon as ML finished installing.

JSalig
Aug 3, 2012, 11:49 PM
Have this same issue but only when it's on battery power. I'm not password protected at the moment so when I open the lid after a few hours I would say it takes about 10 seconds or so to get the cursor moving. The delay is definitely longer than it was with Lion. I only have to deal with it once or twice a day, but it still grates. That's what happens when you get spoiled.

Note: This was happening before the Powernap update as well.

Wowzera
Aug 5, 2012, 11:01 PM
I tried resetting the SMC using apple's guide. Let's see if it helps.
I will report back here.

Update: Didn't solve anything.

leed71
Aug 9, 2012, 05:27 AM
Just to add to the list, I'm also seeing this since the upgrade to ML
(on a 2012 13" MBA)

As others have said, not the end of the world just annoying

buddybd
Aug 9, 2012, 09:22 AM
Permission repair didn't do anything either.

It seems to register every key press, just not as soon as the screen loads.

Team Timm
Aug 9, 2012, 09:23 AM
I was seeing this as well since the upgrade to ML, ran Disk Utility, repaired disk, everything is normal again. :)

SchuettS
Aug 9, 2012, 01:58 PM
I am having this issue as well since upgrading to ML. Doesn't lag when opened within a reasonable amount of time like others have mentioned.

Kal.El
Aug 9, 2012, 05:38 PM
MBA 2011 same problem. SMC will not help. anyone did a fresh install of ML ?
also repaired disk, found some troubles but it seems that they were not the problem

dcorban
Aug 10, 2012, 09:09 AM
Since I updated to ML.. whenever I open the lid to wake my MBA from sleep.. The screen comes up pretty quick but when I type nothing registers for quite a few seconds and then after a lag period of a few seconds I am able to type my password... This was never the case before.
Anyone else experiencing this?

When your Air hibernates, it will not respond immediately. Apple "cheats" by simply showing you an image of what would be on the screen instead of the actual, interactive screen. It makes the computer appear quick to wake up, but in reality, it takes a few seconds coming out of hibernation.

If you open the lid while the computer is just sleeping, and not hibernating, it will be responsive almost immediately.

shamalk
Oct 22, 2012, 10:45 AM
Even without upgrading Lion to Mountain Lion - I still have it (on my 2012 MBA 13")..
This seems like common problem with Mountain Lion.

No hard feelings but I can't ignore the fact that after Steve Jobs passed away, apple's reputation is being destroyed by this kind of low quality stuff. :mad:

tredstone
Oct 22, 2012, 04:22 PM
Apple needs to stop advertising the 'instant-on' feature at this point. This is just unacceptable, and quite frankly my 2010 MBP with a regular HDD was more 'instant-on' than my 2012 MBA.

jacquesmunro
Nov 2, 2012, 05:47 PM
Getting rid of safe sleep has solved this problem for me. Didn't really need it anyway.

http://www.tuaw.com/2011/08/22/why-hibernate-or-safe-sleep-mode-is-no-longer-necessary-in-os/

msjones
Nov 3, 2012, 04:53 AM
I get this lag too on my mid 2012 MBA. Its only 1-2 seconds so its not really a big deal for me.

macinhand
Nov 3, 2012, 05:07 AM
I don't think the issue is restricted to the MBA i have the same issue on my 2011 iMac and sometimes it can be 5 seconds or more before i can type the password! with previous versions it has been instant!

dyn
Nov 3, 2012, 11:04 AM
This isn't even an actual issue, it is expected behaviour with "suspend to disk" (or deep sleep) and it is an annoying one. What it does is read the sleep image from disk and put all its contents back into memory. How fast it does this is entirely dependant on how fast it can read from disk and write to memory. Having an ssd helps tremendously in this case.

What happens with the Air in this case is that when you close the lid it will "suspend to disk" AND "suspend to RAM". I believe Apple calls it safe sleep but it is sometimes also known as smart sleep. This is useful when you swap the battery (which you can't do any more) or when the battery power drops to 0%. The Air apparently has a feature where after a certain period (someone here explained it already so read back; the feature is called "standby") the machine would save power by using the "suspend to disk" and stopping the "suspend to RAM". When you open the lid after that period the machine has to wake from "suspend to disk" which will be slow. Wake from "suspend to RAM" isn't, with an ssd it is almost instant (thus "instant on"). This behaviour seems to have been introduced in Lion and from what I see here it seems to be a bit worse in Mountain Lion (it takes longer).

The obvious way of solving the issue is by turning of the safe sleep function and only using "suspend to RAM". If you do that then be sure to not let the battery life drop to 0% If it's around 20% either sleep the machine and wake it when plugged into an outlet or charge it back up immediately. This should prevent power loss and thus data loss. Another one is to use 3rd party tools that will do "suspend to RAM" up until you reach a certain percentage of battery life. After that it will do the "suspend to RAM" and "suspend to disk" to prevent data loss should the machine run out of power. You can also change the behaviour of sleep to not go into "suspend to disk"-only after this safe sleep thing. This is done by setting the standby parameter of the pmset command (you need Terminal for this). This is what the pmset manual says:

STANDBY ARGUMENTS
standby causes kernel power management to automatically hibernate a machine after it has slept for a
specified time period. This saves power while asleep. This setting defaults to ON for supported hard-
ware. The setting standby will be visible in pmset -g if the feature is supported on this machine.

standby only works if hibernation is turned on to hibernatemode 3 or 25.

standbydelay specifies the delay, in seconds, before writing the hibernation image to disk and powering
off memory for Standby.

FYI: hibernatemode 3 means "suspend to disk" and "suspend to RAM" aka safe sleep (the naming is a bit confusing).

msjones
Nov 4, 2012, 04:16 PM
Strange one this, but since doing the latest updates to safari and iPhoto i've not had the lag. Even after my MBA has slept for 9 hours.

Probably has nothing to do with it, just pleased to problem had disappeared.