PDA

View Full Version : iPhoto library dead...help




mst129
Aug 25, 2012, 12:44 PM
Today I was trying to back my iPhoto library (10.7, iPhoto 11) (less than 5 GB) to Amazon's cloud service. I needed to access the pictures from a different computer for a university project. I noticed Amazon was giving me errors...and when I tried to reopen iPhoto, all photos were gone and I saw nothing but the "To get started..." screen. What's strange is that the iPhoto library's size didn't change, and opening "All my files" in Finder still shows some of the pictures. I tried backing up from Time Machine, but iPhoto wouldn't display anything other than the "To get started..." screen. Thank heavens that I backed up everything on Time Machine...but trying to bring back an earlier version of the library didn't satisfy iPhoto. What did I do? :(



Weaselboy
Aug 25, 2012, 12:48 PM
It sounds like the photos are still there and only the iPhoto database is corrupt. Try this process (http://support.apple.com/kb/HT2638) to rebuild the database.

mst129
Aug 25, 2012, 12:56 PM
Sorry, this didn't work. Should I try reinstalling iPhoto 11?

Weaselboy
Aug 25, 2012, 01:03 PM
Sorry, this didn't work. Should I try reinstalling iPhoto 11?

I don't believe that will help. It sounds like iPhoto is opening and working, but just not seeing the library. Try opening iPhoto (I assume when it open it is blank?), then go to File menu and Switch to Library... and what do you see there? Is the iPhoto Library you want to use selected there?

mst129
Aug 25, 2012, 01:07 PM
No such command is there. :(

Weaselboy
Aug 25, 2012, 01:09 PM
No such command is there. :(

Look at my screen grab. It is there.

You may need to click past that welcome screen you are seeing.

http://i.imgur.com/h6BBu.png

mst129
Aug 25, 2012, 01:12 PM
Even iPhoto Library Manager can't get any files out of this.

----------

Not even the Time Machine backup works!

robgendreau
Aug 25, 2012, 03:03 PM
Can anything else access the iPhoto library? Pixelmator? iMedia Library? Photo Browser in Mail? That could give you a clue as to whether it's iPhoto itself or the library.

mst129
Aug 25, 2012, 03:34 PM
PROBLEM SOLVED!

I was about to give up and bring the computer to the Genius Bar, when I found one last suggestion. I held down OPTION, clicked the iPhoto icon, and sure enough, two iPhoto library locations came up. I selected the one other than the default, and everything came back as if nothing happened!

Thanks everyone! :)