PDA

View Full Version : USB MIA on MBA




Windowsrefugee
Sep 1, 2012, 01:54 PM
This is not really a MBA problem, but probably either a USB or Mac problem, but could not post to the "Mac Hardware" . I have a brand new WD USB drive that is attached as follows to my 2011 MBA Ultra>>>ACD TB >>>USB hub >>> WD HD. I am trying to create a new back up drive, but it keeps disappearing from my finder and even disk utility. Occasionally, I will see an error message saying that it was not ejected properly. Sometimes, it even works. I have changed USB ports and that sometimes works and sometimes does not. I should say that I have also had this problem with an older USB drive which is why WD sent me this new one under warrantee. But not now, I am not sure if it is really a problem with the drive or the USB connections or something on my MBA. It is rather erratic, but seems not to work most of the time. Suggestions?:confused:



charlieegan3
Sep 1, 2012, 01:57 PM
try a range of extra USB devices e.g. mice, kbd, etc and see if they have issues too.

Windowsrefugee
Sep 1, 2012, 02:04 PM
I have tried a number of devices-- in fact I have 2 powered hubs and probably have a total of at least 8 USB devices daisy chained off the ACD TB. I did notice that the Apple USB keyboard has stopped working a couple of times, but seems to respond to just changing USB ports. USB drive is not fixed by changing ports (usually).

Gav2k
Sep 1, 2012, 02:06 PM
Have you tried plugging it in and checking the draw on the USB port?

Windowsrefugee
Sep 1, 2012, 02:09 PM
I do not know how to "check the draw on the USB port"??? I have just plugged it in to ACD TB directly (to assure better power) and it is recognized and working, at least for the moment.

TheRealDamager
Sep 1, 2012, 03:40 PM
I have some usb devices that do NOT like being on a hub at the end of a chain like that - they require me to plug into the Thunderbolt display directly. Your HD may just be one of those devices.