PDA

View Full Version : Software Update not checking every day




kbmb
Oct 3, 2012, 07:28 AM
So according to this page, it says ML is supposed to check for new software everyday:
http://www.apple.com/osx/whats-new/features.html#security

Check for updates daily
Mountain Lion checks for new updates every day, making sure you have the latest software for your Mac.

However that's not the case on my machine....and looking online it seems it's not the case for a lot of people. Looking at the plist file, it seems mine is set to check every 7 days. That's crazy in my opinion.

There is an article here on how to manually change it:
http://osxdaily.com/2012/08/30/change-software-update-frequency-os-x-mountain-lion/

What's funny is this is an upgrade from Lion....where I HAD it set to check everyday.

Are other people seeing this as well?

-Kevin



kbmb
Oct 3, 2012, 03:27 PM
So I went ahead and did the following Terminal command:

sudo defaults write /Library/Preferences/com.apple.SoftwareUpdate ScheduleFrequency 1

And my Software Update happily notified me of the iPhoto update this afternoon.

Not sure if you have to....but I did restart just to make sure the pref would take.

-Kevin

kbmb
Oct 13, 2012, 06:29 PM
Just an update to this.....my Pref file still lists the Frequency of 1.....but it hasn't checked since 10/10.....3 days ago.

The Critical check happens everyday, but it seems the daily check isn't happening.

Why is it Apple can't seem to get some basic things right?

-Kevin

kbmb
Oct 19, 2012, 08:58 AM
I'm convinced this defaults write doesn't help. It still isn't checking SU everyday except for the critical patches.

I even wiped the plist, had it recreated and did the defaults write again....it's 10/19 and hasn't checked since 10/16.

I'm going to leave it alone and see if Apple just hard coded it to check every 7 days regardless of what is in the plist.

-Kevin

kbmb
Oct 25, 2012, 08:09 AM
Well sure enough.....even though I changed the file to set the frequency to 1, it is still only checking every 7 days.

It checked on 10/17 and now again on 10/24.

So it looks like Apple is ignoring that pref or the syntax is incorrect.

-Kevin