PDA

View Full Version : Agent18 60G Videoshield Wetspot Problem




gantha
Dec 17, 2005, 10:32 PM
Hi. I just got my agent18 60G case and when I put it on my white ipod I notice wetspots on the left and right side of the clickwheel. It is also on the backside. i cleaned the case and my ipod many times and put it back on but the spots are still there. the spots looks like thin vertical lines. anyone have this problem? should i use a film first? also anyone have agent18 phone number? thanx.:mad:



bluemouse
Dec 18, 2005, 12:11 AM
I have similar spots, it sounds like. Mine are on a 30 gig black iPod, also with the Agent18 case. What did you use to clean yours? I used iKlear, and it does leave behind a film. I figured that was why. Interesting.

Piarco
Dec 18, 2005, 07:28 AM
Both of you should look on the varying threads on iLounge to do with the clear case problems on both the nano and 5G. It seems they all can suffer from this problem. I had the Contour iSee and Power Support Crystal Jacket for my nano and had the exact same issues. Initially a couple of folks - me included - who put it down to our cleaning problems, but people who had never used anything like iKlear or IceCreme had the same issues.

Basically it just an problem that exists and there is little that can be done about it unfortunately. I gave up and got a Core Case for my nano instead and couldn't be happier.

Chundles
Dec 18, 2005, 08:21 AM
Just put a towel down, should be OK then...;)

gantha
Dec 18, 2005, 11:49 AM
Thanks guys. I cleaned mine with just a cloth. ilounge reports the same problem. contacting agent18 is slow; no phone number!