PDA

View Full Version : firmware problem?




paul9166
Jan 28, 2006, 02:49 AM
Does any body know how to revive a imac g3? After trying to load macos 10.2 and getting the dialogue box about incorrect firmware, the machine will only spin for about 5secs and then die. I've tried resetting the p-ram, new battery, pressing the programmers button on startup and spent hours scannning the net for solutions. I believe that there is nothing physically wrong with the machine and that somehow the software/firmware has become scrambled. I have also tried an external monitor and disconnecting the internal monitor with no progress. I have heard that you can remove the hard drive and link it to another computer to revive it, but is it a hard drive problem or main board problem? Can fire wire be used to network it to another machine?



mad jew
Jan 28, 2006, 07:19 PM
Well, have you installed the newest firmware (http://docs.info.apple.com/article.html?artnum=86117)? :)

paul9166
Jan 29, 2006, 04:27 AM
Unfortunately not. But the a dialogue came up asking to continue or cancel. When I cancelled the remainder of the installation it was too late. The machine is a dv400 10gb slot loading imac g3 grape, bought in December of 1999 and had no known failings until that point.