PDA

View Full Version : 20" iMac Mini DVI port dead




mikehowett
Sep 30, 2006, 09:22 AM
I purchased my iMac in March of this year and about a week ago I noticed that the mini dvi port no longer works. What options have I got to get it fixed? The screen has also developed about 5 dead pixels since i've had it, which i'm pretty sure were not there when I got it. Would I be able to get both replaced under warranty?

Thanks in ad!

:)



Sam0r
Sep 30, 2006, 10:20 AM
Well its still in warranty if you haven't mucked about inside.

Either phone apple's tech support or take it into a store, they should repair ir free of charge.

nightelf
Sep 30, 2006, 01:09 PM
Take it to an Apple Store. Good luck.

2nyRiggz
Sep 30, 2006, 02:43 PM
To check if the port is really working you can check in system profiler and see what it says in there but take it back.

Apple should fix it or replace it for you if its only five months old.



Bless

mikehowett
Sep 30, 2006, 02:55 PM
To check if the port is really working you can check in system profiler and see what it says in there but take it back.

Apple should fix it or replace it for you if its only five months old.



Bless

Never thought of that. But I just tried it and nothing showed up, however if I push and hold the mini dvi connector into the iMac the display works. There must be a loose connection inside. How would they fix that? New logic board or just fix the loose connection?

Also, what about the dead pixel problem?

:)

2nyRiggz
Sep 30, 2006, 03:02 PM
Take it in so they can fix it up for you or replace it. I'm not sure about dead pixels(I'm not sure if it is covered).



Bless

mikehowett
Oct 15, 2006, 10:26 AM
Just thought I would give a quick update.

Finally managed to get to my local Apple store today. Explained the problems to the guy, who was very friendly and helpful and they're gonna replace the logic board and the LCD :D Result! He also said he would fast track it because it's the second time i've had to have it repaired :)