PDA

View Full Version : iTunes plays song, but iPod won't




tech4all
Oct 29, 2006, 09:35 PM
I have this .wav file that plays fine in iTunes, but for some odd reason when I try to play it on my iPod, the iPod reverts back to the main menu. I tried reseting the iPod while holding down Menu and the center button, but nothing. iPod is 4G with black and white screen (40GB) and iTunes 7.

Any ideas? :confused:

P.S. While attempting to play the song on my iPod now I noticed that if I pause the song before it goes back to the main menu and I click the center button so I get the seek mode, I can scroll throughout the song, but when I stop scrolling the little dot goes back to 0:00. It's as though the iPod thinks the song is 0:00 long. Weird.



iMeowbot
Oct 29, 2006, 09:46 PM
You could set up the iTunes preferences to do imports as AIFF for now (set it up to match whatever settings are used by the WAV, from its get info panel), and then ctrl-click to convert that track. That ought to bypass whatever is in the way, and it leaves the original WAV intact just in case.

Nermal
Oct 29, 2006, 09:53 PM
iTunes and iPods use different decoders, and as such they handle damaged files differently. I've seen countless (well OK, two :o) files that play perfectly in iTunes but not on my iPod. A lossless conversion has worked in both cases.

Fearless Leader
Oct 29, 2006, 09:55 PM
change to lossless encoding and change .wmv to it. The ipod supports lossless better.

tech4all
Oct 29, 2006, 10:02 PM
Thanks everyone for their reply's. :)

I'm somewhat did what you guys said. I right clicked the file and converted it to AAC instead of WAV. I updated my iPod to reflect the change, and it seems to play fine now. That's odd as I never encountered this problem where iTunes could play a file but the iPod can't.

Thanks again!