PDA

View Full Version : Steelfist Re: Ibook lost sound




drov
Nov 15, 2006, 09:02 AM
Saw a problem a member (steelfist) had awhile back regarding loss of sound from internal speakers. I needed to know how that was resolved since I have the exact problem on wife's ibook.

Apple iBook Notebook 12.1" M9846LL/A (1.33 GHz PowerPC G4, 512 MB DDR SDRAM, 40 GB Hard Drive, Combo Drive, Built-in AirPort Extreme

Problem: Internal speaker option in sound preferences GONE all of a sudden. Only headphone option exists. Headphones sound good and so does any external speaker plugged in to that jack. But internal speakers are gone.

Tried: everything except reinstalling OS X. I've messed with opening and closing Garage Band, checked Midi defaults, tried to trip jack into not thinking headphones was plugged in - did the PRAM, power reset - no mutes on or sound lever out of balance either. Want to avoid sending unit in for repair if I can do it myself.

Need to know: Would opening the unit and unplugging / plugging the sound jack or speakers (if possible) make the system "see" the internal speakers? Or should I reinstall operating system? Just afraid of losing files.

Thanks for any help

David



diadem
Nov 15, 2006, 09:20 AM
if it is missinmg from the pref then it going to be a software issue/drivers, back up and reinstall.

drov
Nov 15, 2006, 10:23 PM
Diadem,

Thanks for reply. I reinstalled OS X from my discs and still have no sound from internal speakers and no option in preferences other then headphones.

Is there a different, more complete reinstall? I did the one where it remembers all my settings. I didn't erase and start from total scratch. I have a feeling it's hardware. But perhaps the drivers didn't get reinstalled the way I did it.

Any other suggestions appreciated. Thanks again