PDA

View Full Version : What The Heck is an "Invalid Node structure"? (Disk Utility)




BiikeMike
Mar 25, 2007, 11:22 AM
My Computer has been acting wonky lately (What else is new?) Its a CD MPB 2.16, 10.4.9, 2 gigs APPLE RAM.

I have been getting a lot of dropped frame notices in Soundtrack pro, and it straight up froze yesterday while running a live show..... That = NOT GOOD.

I ran ONYX, and it said something was wrong with the startup disk. Out comes Disk Utility. When I click "verify disk" I get an error after "Checking Catalog file" that says

Invalid node structure
The volume Macintosh HD needs to be repaired

Error: The underlying task reported failure on exit

So, out comes the Startup DVD. Run Disk utility, click "repair disk" I get the same error, "the underlying task reported failure on exit" and it won't fix it.

Whats the deal??



Veritas&Equitas
Mar 25, 2007, 11:24 AM
Are you sure you booted from the disk? I had the same problem when trying to install Vista. Popped out the OS X install disk, booted from it, ran disk utility, and repairing the disk worked for me?

BiikeMike
Mar 25, 2007, 11:49 AM
yep, positive it was from the disk. you can't repair the startup disk otherwise.

CanadaRAM
Mar 25, 2007, 12:07 PM
The Invalid Node Structure means that the cataloging system that keeps track of where everything is on your hard drive is b0rked. TechTool Pro may fix it, as may DiskWarrior -- however some people have reported no success with both. If you haven't already make sure your data is backed up! Do it now! Ultimately, a reformat of the hard drive is the last solution.

http://www.macosxhints.com/article.php?story=20070204134513557

If errors like these repeatedly crop up, assume that your hard drive is failing.

Snide
Mar 25, 2007, 12:33 PM
I had this same issue (Macbook), and Diskwarrior replaced the directory and solved the problem.

SC68Cal
Mar 25, 2007, 12:53 PM
http://www.rixstep.com/4/2/onyx,01.shtml
http://www.rixstep.com/4/2/onyx141,00.shtml
http://www.rixstep.com/4/2/onyx141,01.shtml

delete the Virtual Memory files (swapfile)

Huh? HUH? Why? Why risk making the system unstable when you can safely reboot? Anybody can delete the swapfiles - especially if they've already got your password... Thanks but no thanks, amigo.

Don't use onyx. I'd put a bet that using onyx ********* your disk.

BiikeMike
Mar 25, 2007, 02:04 PM
Good theory there, Amigo, only problem with it is that I installed ONYX AFTER the problems started. Thought it might fix it.

Guess I'll be doing a SuperDuper! backup tonight and then calling AppleCare. Not that I don't think I can't do it without somone from India on the phone, I just want them to have on file all the problems I'm having with this freakin thing!

Angrist
Mar 25, 2007, 02:41 PM
Thats an error that Disk Utility simple will NOT fix, regardless of what you boot off of.

Diskwarrior has fixed the error for me a couple of times.

But the underlying problem is that something is fscking up your filesystem. Many times there is a hardware problem that is messing up your HD writes, if you don't fix this then you'll be repairing / re-installing all the time. Hard shutdowns sometimes do it, bad RAM also causes it. My recommendation is to run a memory tester such as memtestosx and see if the RAM is to blame.

Mattydj
Mar 25, 2007, 03:01 PM
i got that problem so i formatted and at that moment the hd failed.

BiikeMike
Mar 25, 2007, 07:17 PM
Yeah, This is GREAT!

Now it wont recognize my external drive!

And I know its not the RAM, Because I just had it in the Apple store not 2 months ago for ANOTHER problem that resulted in complete data loss. they Checked the RAM, and it was fine.

This is REALLY starting to Piss me off!

IJ Reilly
Mar 25, 2007, 07:30 PM
CanadaRAM is right on the money. You need a heavy-duty disk repair utility and you need it now!

BiikeMike
Mar 25, 2007, 07:53 PM
UH OH!

I'm assuming this is not good??

I finally got it to recognize my external (How, I'm not sure, I switched from Firewire to USB a few times, then put it back in my desktop via FW, and ejected it, and put it back into my Laptop via USB :confused::rolleyes: )

Anyway, Got SuperDuper! Up and running, and it "failed to copy files from Macintosh HD to MacBookBackup" (MacBookBackup is my backup partition)

The Last few lines of the Log are as follows: I have no idea what any of it means


| 08:38:41 PM | Info | /
| 08:38:44 PM | Info | /Capture Scratch
| 08:38:44 PM | Info | /usr
| 08:39:25 PM | Info | WARNING: Caught I/O exception(22): Invalid argument
| 08:39:25 PM | Info | WARNING: Source: /usr/bin/automake, lstat(): 0
| 08:39:25 PM | Info | WARNING: Target: /Volumes/MacBook Backup/usr/bin/automake, lstat(): 0
| 08:39:25 PM | Info | Attempting to copy file using copyfile().
| 08:40:01 PM | Info | Attempting to copy file using ditto.
| 08:40:12 PM | Error | ditto: /usr/bin/./automake: Input/output error

BigPrince
Mar 25, 2007, 07:56 PM
$100 Diskwarrior, probably a partial recovery.


Tech Tool Pro may work, but Diskwarrior is the best option.

Otherwise repartition the drive and reinstall and start from scratch.

before reinstalling, do the extended hardware test to make sure the drive itself is still ok.

IJ Reilly
Mar 25, 2007, 08:30 PM
Try to drag-copy your important files to the backup drive.

The last time I needed DiskWarrior, the recovery was 100% from an un-mountable and unbootable drive.

CanadaRAM
Mar 25, 2007, 08:37 PM
IIRC: If DiskWarrior can read the files on the drive (IF) then before repairing them, it will give you the option of a temporary disk image, from which you can back up files - so be ready with an external volume mounted to take the files.

Expect that some of your files will be damaged beyond recovery.

BiikeMike
Mar 25, 2007, 08:46 PM
Now I'm running Carbon Copy Cloner, and it gave me an I/O error that had to do with iWeb, but I hit skip, and it seems to be working.....

I'm frightened here guys......!

BigPrince
Mar 25, 2007, 08:50 PM
your image probably wont mount...but still worth a try since its free.

IJ Reilly
Mar 26, 2007, 12:27 AM
IIRC: If DiskWarrior can read the files on the drive (IF) then before repairing them, it will give you the option of a temporary disk image, from which you can back up files - so be ready with an external volume mounted to take the files.

Expect that some of your files will be damaged beyond recovery.

Running DiskWarrior generates this message as a text file, within the Damaged Items or Rescued Items folders:

DiskWarrior can create two new folders while rebuilding the directory. The first folder is the Damaged Items folder. It contains files with allocation errors or other errors which affect the data contained in the files. The second folder is the Rescued Items folder. It contains files and folders that were orphaned and/or recovered. Orphaned files and folders are items that were missing their enclosing folder. Recovered files are files that had an entry in an inaccessible portion of the directory. These files may have been previously lost or thrown away.

Review the DiskWarrior report you saved to determine which items in the Recovered Items folder were orphaned and which items were recovered. You must inspect the damaged and recovered files to determine which, if any, had missing contents. You can then replace, recreate or discard unusable files.

BiikeMike
Mar 26, 2007, 04:58 AM
your image probably wont mount...but still worth a try since its free.



Why is that? I'm not making an image, I'm making a clone.

I got another error..... Had to do with Epson printer drivers

rhoydotp
Mar 26, 2007, 06:49 AM
have you ever tried

fsck -y /dev/disk0s2

where disk0s2 would be your "/"

it is your inode structure that has been screwed up.

BigPrince
Mar 26, 2007, 08:52 AM
Why is that? I'm not making an image, I'm making a clone.

I got another error..... Had to do with Epson printer drivers

there the same thing and your copying an unbootable drive now, often times making an image does not fix it without a third party utility.

Have you done the extended hardware test? All your efforts could be futile if your drive went bad.

Do you back up your data? If so, then just repartition and start from scratch. If not, dish out $100 for diskwarrior.

dingdong
Apr 10, 2007, 07:21 PM
hey guys i'm having the same problem with invalid node stucture.
i'll be getting a external hard disk soon to backup files..
will this solve the issue if i format the drive and reinstall mac os?

i really hope its nothing to do with the hard disk being damaged. i am running on mac osx fine atm nothing is happening majorly yet and i feel that this invalid node stucture does not sound right so i wanna fix this...

has this affected my hard disk at all?

cheers

BigPrince
Apr 10, 2007, 07:26 PM
Run the Extended Hardware test found on your install CD that first came with your computer.

This will probably take near a half hour if successful.

If the hard drive part is successful, then repartition should solve your problem and you will be able to move on.

If not, then it is very likely your drive is screwed and will need to be replaced.

IJ Reilly
Apr 10, 2007, 07:33 PM
An "invalid node structure" is almost certainly not a hardware problem, it is almost certainly a logical problem on your hard drive, which can be fixed with drive repair software, such Disk Warrior or Tech Tool. You do not want to assume worse until you have tried this method of disk recovery.

BigPrince
Apr 10, 2007, 07:38 PM
An "invalid node structure" is almost certainly not a hardware problem, it is almost certainly a logical problem on your hard drive, which can be fixed with drive repair software, such Disk Warrior or Tech Tool. You do not want to assume worse until you have tried this method of disk recovery.

My most recent encounter with this issue was for me a hardware problem, so thats why I suggest running the hardware test(free and fast) just to alleviate any concerns so you don't waste time if the problem happens again shortly after. If all my data was backed up and I did not own Disk Warrior or Tech Tool then I would repartition(free and fast).

I would not recommend Tech Tool Pro for this job. Tech Tool is better for diagnosing, but not necessarily for fixing. Disk Warrior is made to fix and thats it. If you decide that you need data that you are willing to pay for then skip right to Disk Warrior, IMO.

If you have everything you need, then why pay, just repartition?

But its good that we did clear up any confusion and your points are valid.

IJ Reilly
Apr 10, 2007, 07:44 PM
Because repartitioning means wiping the drive and reinstalling OSX? This seems like overkill to me.

A invalid node structure being a hardware problem is a new one on me.

I also prefer Disk Warrior for this kind of issue, but I know some like Tech Tool so I wanted to be fair.

BigPrince
Apr 10, 2007, 07:51 PM
Well its free so for me it would be worth it.

The Hardware problem may of been unrelated.

Disk Utility told me it was an Invalid Node Structure and when I decided to run the hardware test, the hard drive test failed.

Tech Tool Pro detected the error but failed to repair it.

Disk Warrior was successful in getting most of the data off the drive by making a image of it and letting it mount.

I think its called "Mounting it Virtually," not sure.


EDIT: IF these two events are typically unrelated, then your right that one would not need to run the extended hardware test.

dingdong
Apr 10, 2007, 08:14 PM
i've just done a extended hardware test and saids no problems found.

i booted up from the disk and asked to partition my harddisk.. i guess this is going to erase all my files.. so i'll have to backup my files on a external hard disk or something hey

BigPrince
Apr 10, 2007, 08:59 PM
Ya, partitioning your drive will erase everything. If you still have files to back up then you will need Disk Warrior($99) to repair the error.

You might be able to mount it "virtually" and access your files, however I don't recall though.

dingdong
Apr 10, 2007, 09:18 PM
yeh i still have files to backup.but i can't back it up until i get my external harddisk in couple days...
why do i need disk warrior to fix this? doesn't repartitioning the drive do the job and fix this invalid node stucture? if it wasn't for onyx i wouldn't of thought i'd have invalid node stucture coz mac ox is still working ok for me for some reason.why is this if i have this invalid thing going on?

BigPrince
Apr 10, 2007, 09:21 PM
If your still booting and able to access your computer then I'm clueless. These errors in my experience bring the OS to its knees and it is unable to do anything.

dingdong
Apr 10, 2007, 09:29 PM
but u still reckon i should repartition my drive and install osx again? would that solve the invalid node structure?

i'm actually using my macbook now and cannot seem to find any problems running it.. boots everytime i start it up. i'm just worried that there's gonna be something wrong with it in the long run if i don't fix this asap.

:confused:

BigPrince
Apr 10, 2007, 09:31 PM
someone else is probably more qualified to answer that then me since as far as I know it should not work at all.

Unless Disk Utility says its invalid, I would leave it alone but make sure I have everything backed up.

This however should not be possible, So I do not think you have an invalid node structure.

dingdong
Apr 10, 2007, 09:42 PM
it saids invalid node structure whenever i verify disk in disk utility. and i tried repairing but won't let me for some reason (using the installation disk)


this is what exactly it say when i try verifying it

Verifying volume “Macintosh HD”
Checking HFS Plus volume.
Checking Extents Overflow file.
Checking Catalog file.
Invalid node structure
The volume Macintosh HD needs to be repaired.



Error: The underlying task reported failure on exit


1 HFS volume checked
Volume needs repair

--
i am still be able to log on to osx without any problems

gee i have no idea whats up with it telling me i have this problem when i can still bootup to osx..


my specs are C2D 2Ghz 120gb using os x 10.4.9
:confused:

IJ Reilly
Apr 10, 2007, 10:58 PM
why do i need disk warrior to fix this?

You only need it if you don't want to wipe the drive and start over.

dingdong
Apr 11, 2007, 03:31 AM
so i guess i shouldn't do anything for the time being since its running ok..?

BiikeMike
Apr 11, 2007, 08:54 AM
DingDong,

When I talked to the "product specialist" at Apple, I said I had done a bunch of research and that I found out that error basically meant my harddrive was useless and needed to be reformatted. He was a bit reluctant to just say yes, but that is what it boiled down to.

I sent mine off to the doctor because it had a plethera of other problems as well, and it should be back in the next few days, i'll let you know what they did.

IJ Reilly
Apr 11, 2007, 10:31 AM
so i guess i shouldn't do anything for the time being since its running ok..?

I wouldn't ignore it, because it won't heal on its own and could cause the drive to become unbootable at some point in the future. If you can clone the drive to an external drive (using SuperDuper or CarbonCopyCloner), then reformatting the problem drive, and cloning back, makes sense. Otherwise, if it were me, I'd go the Disk Warrior route.

BikeMike, I hate to say it, but sometimes the Apple tech support people give out some awful advice. An "invalid node structure" is a logical error, not a mechanical error. I suppose it could be caused by a mechanical problem with the drive, but I would not make such an assumption, since it can be caused any time the drive writes improperly.

BiikeMike
Apr 11, 2007, 04:07 PM
Well, I just got my computer back (Really impressed with the speed of AppleCare, Sent it out on Monday, got it back today) and they replaced my hard drive. It may have had other things wrong with it, but they only thing I know about it was the errors I posted above.

dingdong
Apr 11, 2007, 04:22 PM
oh so i guess it was a dodgy drive then hey...

---
in the meantime i hope i can back up with (superduper) in time before it does anything dodgy, as soon as i get my external harddisk.

i'll try repartition it after backup and reinstall mac osx and see if it still states invalid node structure. if it does i best off go to appleshop and get it fixed i reckon

dingdong
Apr 16, 2007, 08:10 PM
just repartitioned and re-installed osx and its fine now. it does not appear to have invalid node structure now. :D


have no idea what happened and why it said it before coz everything seems fine even when it had invalid node structure.

BigPrince
Apr 16, 2007, 08:21 PM
good job.glad everything worked for you.

MacDann
Apr 16, 2007, 08:48 PM
I just came off an "invalid node structure" problem on a client's computer last week, and after a lengthy exchange with the folks at Alsoft (DiskWarrior) the decision was to do a complete wipe and clean install. To their credit, had we been willing to spend more time on the problem they felt like it could have been fixed, but we didn't want to invest the time and effort.

Interestingly enough, the machine was running fine, the user only had two indicators that something was up - at the very beginning of startup when the apple comes on the screen, the file folder/question mark icon appeared for just a split second and then the apple appeared, and when they attempted to run Disk Utility to verify/repair the disk, it cacked as one of the previous posters described ("the underlying task reported failure on exit.") Attempts to fix it using DW resulted in an error where DW would run and come up with the fixes for the drive, but would not allow the repairs to take place due to "a Mac OS services failure."

Since it was running OK, we were able to use Disk Genius to make a copy of the disk on an external drive, then do a complete erase (with zeros) and reinstallation of the OS.

Once we did this and were satisfied that the new install was OK, I mounted the external drive that had the clone of the original drive and used the Migration Assistant to copy all the user's old apps and user data to the new (clean) drive.

It's been working fine for a week, so I closed the ticket. Sadly, this was the first time in almost eight years that DiskWarrior didn't bail me out. I can't complain - it's still the best utility out there, IMHO.

MD

Kreuz11
Nov 21, 2007, 07:13 PM
Is Disk Warrior going to do me any better than Disk Utility as far as making an image of the damaged drive? I have my G4 17" iMac booted from my external FW drive. Every time I try to create an image from my internal drive it fails and says: "Unable to create "disk0s5.dmg" - Input/output error. What does this mean?

IJ Reilly
Nov 21, 2007, 07:32 PM
Is Disk Warrior going to do me any better than Disk Utility as far as making an image of the damaged drive? I have my G4 17" iMac booted from my external FW drive. Every time I try to create an image from my internal drive it fails and says: "Unable to create "disk0s5.dmg" - Input/output error. What does this mean?

Why are you trying to make an image of your drive?

DiskWarrior is a hard disk repair application. It can perform rescue tricks that Disk Utility cannot, but it doesn't make disk images.

Kreuz11
Nov 21, 2007, 11:26 PM
I just need to recover all my data before I reformat and I was hoping Disk Warrior would help. Image or whatever I just want to get stuff off of the internal drive so I can wipe it and start over. I've got to get Disk Warrior working and then I'm sure it'll make more sense. I think I saw a fix to the problem I'm having with that up above, so I'll tackle it on Sun. when I return.

Jama
Jun 15, 2009, 03:28 PM
I am responding in this thread because my problem seems to be similar but I found a solution that does not appear to be posted on this site.

The story:
I am using a 20", Intel, iMac, running the 10.4.11 OS.

I was having problems with a Lacie external drive (1 TB with firewire). When trying to solve the problem I used Disk Utility to Verify the external drive. I then thought, "Well, let me check my HD drive while I am here." When I attempted to Verify my Mac HD drive I got an error similar to those described here except it said, "Invalid Node Height" instead of "Invalid Node Structure." Disk Utility did not offer me an option to "Repair;" the button was simply not active. I read all the things here about partitioning, etc. but was not convinced I needed to go that far. My computer would boot without problems and other than an annoying screen flicker, which has been a constant issue with this computer, everything seemed to be working. Still, I reasoned, as others in this thread have, that I needed to fix the problem before something bad happened.

Here is what I did to Repair the Mac HD:
I shut down the computer and unplugged everything except the mouse and keyboard and turned the comp back on.

I then restarted my comp using Disk 1 of my MAC OS Installation disk as my start up disk instead of my Mac HD. I held down "D" during restart which I thought would open an Apple Hardware Test. My idea was to check the drive for a hardware problem. Instead of hardware test prompts, I was asked to select my language, I released the "D" key, selected English as my language, and got a screen with an activity bar saying "Preparing Installation" or something. Then, I was offered a window asking me if I wanted to proceed with the Installation of software apps that came with my computer. Ignoring this window, I went to top of my screen and found the Disk Utility located on the start up disk. I used it to check the Mac HD and got the same old Invalid Node Height error, but this time I was offered an opportunity to repair, i.e. the button was active. I chose Repair, waited perhaps 20 mins for the repair to complete, verified the Mac HD just to be sure, and then restarted the comp using the Mac HD drive as the Startup Disk.

Everything seems to be fine, no data loss as far as I can tell. I have the same image for my desktop etc.
Hope this helps someone. Peace.

BigPrince
Jun 15, 2009, 05:15 PM
Great! Good trouble shooting!

The reason the "repair" was not given as an option is because you can not attempt a repair from a drive that you are actively booted from.

MazMan007
Sep 21, 2009, 11:36 AM
would running an upgrade from the snow leopard disc fix this problem and not erase personal documents on my mac?

derbis
Nov 16, 2009, 03:56 PM
Hello.
Last two months i has this problem with freezing mac and "invalid node structure".But i repaired it, than i reseting my mac PRAM and NVARM.
http://support.apple.com/kb/HT1379

But today, my hdd freez again, than i click on Disc utility. So i think, i change my hdd in fast time..

And my friend has this problem too, he change hdd, but problem, do not repaired. So he reset PRAM and NVARM. And it was okay. So i not be shure, that hdd changing helped me..

(Sorry for my bad english language)

kciociola
May 20, 2011, 05:31 AM
The suggestions to "back up all your data because your hardware is b0rked" are all well and good, but what do you do if the disk throwing the error is your backup disk.

I just noticed this issue last night when a Time Machine backup to this 1TB LaCie failed. I ran Disk Utility, which couldn't repair the problem and after a restart or two, the disk would no longer mount. This meant that I couldn't get the location of a .sparsebundle file to run the disk repair from the command line.

So...my only recourse appeared to be reformatting the drive. So I did.

The first backup (250+ GB) ran successfully overnight and I ran a disk verify using Disk Utility just now and I'm getting the same error.

I'm panicked because, not only do I no longer have any backup history for anything, I have no backup whatsoever.

Any suggestions?

anjajd
Jun 18, 2011, 09:39 PM
I stumbled upon this thread via the magical google search engine, and I chose macrumors, of course, for all the help you've given me for when my mac-savvy boyfriend wasn't in arm's reach and I needed help with a macbook issue.

Anyways, the issue he and I are going through relates rather well with this forum both the "invalid node structure" and 3rd party disk utility repair software.

Onto the story:

The Mac in question is a 2006 24'' Mac that has seen a lot of use, but is very well taken care of. Only one user (my boyfriend), and he does take very swell care of his mac (routine maintenance/updates) and used apple products all his life... so it's not like he's new to the whole program like I am (which is why I usually run to him... hahah!). The only repairs/etc. that have been done to the Mac: a new logicboard (replaced a faulty one) and an installment of upgraded ram by a certified apple technician whom we know personally.

The Mac had been freezing intermittently, and the only way to get it into working order was to force it to reboot. It would seemingly work fine afterward with no ill effects. However, last night we were having some inside joke fun (poking fun at a genre of music) and it froze... we forced a reboot and it came back up, we did a little more surfing and then called it a night after that. At 11 am this morning, he went to his Mac to try to boot it up and it did the "folder w/ ?" thing.

From here he tried a few things. He tried using his first-gen iPod that he's fashioned into a boot disk (it's worked on other macs in the past, trust me.) With no avail, in fear that the iPod had given up the ghost, he tried a regular boot disk. Nothing. Then he tried connecting to a friend's mac. Nada. It wouldn't boot for *anything!*

So we had to resort to opening the mac ourselves. (Not recommended for anyone under apple care, still qualifies for apple care, who doesn't know a lot about opening up their computers, or working on the inside of electronics, particularly computer parts!)

We have a hard drive/sata enclosure already, and the required tools to get INTO the Mac itself, so we fashioned the appropriate static-free workstation and got to work. After getting the hard drive out (500GB seagate barracuda that came factory installed by Apple), we put it in the enclosure and hooked it up to our roomate's Mac.

We have both Tech Tool Pro and Disk Warrior floating around on a usb external drive. We ran the disk utility first. It went nuts. Couldn't verify the drive, we tried to repair it. It came up with the "invalid node structure" error and some other lines I can't remember before I was booted out of the office chair and my significant other took over.

We then tried to look into the disk and saw that most of the file structure, while there, it was missing a *lot* of stuff. All his iTunes music, movies, more importantly, his emails from the last 4 years, work files he's spent 100's of billable hours on. He has had a backup before, but not recently. I dubbed it aggressive spring cleaning, but remembered we had programs to help, and pointed him to this thread.

We ran Tech Tool Pro first. It couldn't even handle doing a surface read of the drive. It *crashed* the program.

So without fiddling more with the program, we moved to Disk Warrior. Our savior. Lots of errors. I could paste the type the report to you, but it's rather long, but basically, someone else said it, it looks to be possibly mechanical/logical. The directory was all messed up, there were numerous errors, but needless to say, Disk Warrior was able to get us (so far) to where we need to be to copy the files we most direly needed (we're just going to nuke the rest). We're not sure if there's a mechanical problem involved in the drive, as it said there were 16 problem sectors/nodes on the disk.

The plan: We're not going to take our chances, as we've bought nearly the same drive (same brand/size/etc., just 1TB instead of 500GB). We're going to nuke the drive after everything's done copying over and install a fresh OS on each hard drive (the problem one, and the new retail one).

WHAT he plans on doing with the old one, not sure. We already have a USB external and a replacement drive for him... lol.

But, that's the plan thus far. Hope this helps people's questions. Put simply: The disk utility couldn't repair what damage there was. It couldn't get precious files that he would've been (and had been) billing his clients for. Now, he has those files again, as well as other vital files that we really didn't want to part with. Well worth the money to get the program. Especially if you can manage to keep it on an external drive/disk and install it on your macs and run it as you need it, like we do.

In our situation, we will probably have to nuke the drive anyways, but as another topic poster mentioned, you may be able to save the drive with this utility, and the normal disk utility can't do it. It can possibly save you from repartitioning and wiping everything clean. If so, that saves you a huge step, and a lot of hassle. If you're like us and have a LOT of very valuable software (and files you create along with that software!) that you accumulate over the years... you can't simply just "nuke" your drive, especially if you've been slightly negligent about your last back-up. And as mentioned, some Apple technicians will simply shrug their shoulders and tell you they have to nuke the drive and start fresh, or replace the drive completely, when it can be saved, and save you resources.

IMO, we do have the time to do it, even if in the last 12 hours he could have been coding a client's website or working on a work file. But we've probably cut the cost of repairing his out-of-Apple-care Mac in third today. And that's being conservative.

Hope this helps.

bobbybarnacle
Jun 24, 2011, 02:40 PM
On my intel based imac, I too downloaded onyx went through same proccesses with installation disc and everything. And now I would like to download diskwarrior and fix my mac disk, but the problem is, ever since I ran the installation disk, I wasn't able to go back on my normal disk. I would reboot back to macintosh hd and a little loading bar would come up under the apple and pinwheel then it would go away and I waited 2 days and the pinwheel kept spinning, I would like to at least back up all my files on to my external hard drive or fix the disk which I can't do if I don't have access to my actual normal drive.
Can u please help me

bj00rn
Aug 30, 2011, 03:13 AM
Had the samme error messages on my external 500GB WD drive. I ran a directory rebuild in DiskWarrior and it seemed to fix the problem, everything seems fine so far :)

BethanyGrace
Sep 2, 2012, 07:48 AM
I stumbled upon this thread last night and I'm hoping to get some assistance since this is the first time I've had to deal with anything like this.

I have a 5 year old MacBook running on Leopard that's recently been having more and more issues. I decided to finally get an external hard drive to back everything up in the event it decides to bite the dust. I used Carbon Copy Cloner to copy the hard drive and during that process it turned up a list of corrupted files. I went into disk utility to check things out and when I verified the disk, it show this node structure error message. I busted out the installation cd to run disk repair on it and at the end of all that it says: "The volume Macintosh HD could not be repaired after 3 attempts. Error: the underlying task reported failure on exit. 1HFS volume checked: 1 volume could not be repaired because of an error. Repair attempted on 1 volume: 1 volume could not be repaired"

From what I've been reading, it sounds like my most economical/best option is to wipe the hard drive and reboot to see if that corrects the issue. I was wondering if someone could walk me through that process in laymen's terms because I'm scared of messing everything up. Would I reboot from the installation discs then re-clone my files from the external hard drive?

JKatLarge
Sep 22, 2012, 10:16 AM
Hello,

I am a complete greenhorn trying to fix this node structure problem on my MacBook pro.

Using it today, it froze up for a while when I was browsing with safari, then recovered, then froze completelty. I hard-shutdown, restarted - grey startup screen appeared and stayed there for eternity, with spinning gear. I have followed many of the instructions here... ran disk utility to check problem: invalid node structure.

Now I am running extended hardware test.

My main problem (of my own creation) is that I have never backed up my HDD. Idiot.

Is it possible to backup/recover any of my HDD just using Disk utility? Do I need one of these cloning programs? And if so, how do I use them, given that I can't actually startup my computer at all?

Glad this thread is already in existence! Would appreciate any help!

switon
Sep 22, 2012, 11:33 AM
(removed)