PDA

View Full Version : HEELLPPP!! Halo will no longer run!




iTim314
May 11, 2007, 08:06 PM
Okay, I've posted this problem in another thread thinking it was related to another software (Quicktime) update. Now that the problem has come back, I'm conviced there's something else, something more extreme, wrong.

I'm Running Mac OS X 10.4.9 on an iMac G5, with ALL the most recent software updates as of 5 minutes ago, just for reference.

My problem: I try to Run Halo (v1.5.2 PPC), and once the 'Halo' image comes up, and the screen resolution changes, it imediately closes saying "Halo Unexpectedly Quit: Close, Report, Reopen?"

This same problem occured about 2 weeks ago. Like I said, my origional hypothesis was it was related to the Quicktime Update, since I was playing Halo mere minutes before the update, and was unable to do so right from start up. Though after 2 reinstallations, Halo started working again.

Well, it's back. And it's not cooperating this time, and I don't know what's causing it.

I've tried EVERYTHING. To show you my most recent attempt on how thurough I've been, going WAY out of the way, here's my very detailed process on how I have repeatedly reinstalled Halo. This is aggrivating me.


1) Spotlighted 'Halo' and 'Bungie' and deleted EVERYTHING remotely related to Halo.
2) Repaired Permissions.
3) Installed Halo (v1.0.2) right off the disk.
4) Repaired Permissions.
5) Re-copy 'Shaders' off the disk manually.
6) Repaired Permissions.
7) Restart OS X.
8) Tried Halo as v1.0.2, Failed.
9) Installed Halo Update to v1.5.2
10) Repaired Permissions.
11) Restart.
12) Tried Halo....

And it did the exact same thing.

I'm officially out of ideas. Any help? I've got a clan game tonight in about an hour and twenty minutes.



lancestraz
May 11, 2007, 08:30 PM
Create a new user account, install Halo, run Halo.
Does it work?

iTim314
May 11, 2007, 08:41 PM
Nope. Same problem.

lancestraz
May 11, 2007, 08:57 PM
Nope. Same problem.
Ok. Then the problem must lie deep in the bowls the system files.
Your only option might be to reinstall OS X.

iTim314
May 11, 2007, 09:03 PM
I was afraid of that.

Does that mean, back up everything and do a fresh install?

We've got 4 users, with about 45GB of data total. I have no External HD.

Is that the only solution?

zeedee-h
May 11, 2007, 09:15 PM
have you tried a program like app delete?

http://www.apple.com/downloads/macosx/system_disk_utilities/appdelete.html

iTim314
May 11, 2007, 09:48 PM
Unfortuately, that didn't work either.

Nermal
May 11, 2007, 09:55 PM
Quit all apps, move everything from /Library/QuickTime onto your desktop and try again.

iTim314
May 11, 2007, 10:09 PM
Sigh.

Still no luck.

Well I missed my match.. :(

lancestraz
May 11, 2007, 10:19 PM
You are using a legit copy of Halo, right?

iTim314
May 11, 2007, 10:22 PM
Indeed. Bought it off the Apple website shortly after we bought our iMac about 2 years ago...

Bobdude161
May 12, 2007, 01:04 AM
holding Apple key while starting Halo? Messing with preferences?

iTim314
May 12, 2007, 09:12 AM
holding Apple key while starting Halo?

What is that supposed to do? I tried it, but nothing unusual happened, and it still didn't work.

Messing with preferences?

You mean the preferences in the window that pops up before the game launches? I've tried all sorts of configurations. No luck.

iTim314
May 12, 2007, 10:15 PM
Okay, after no hope of any quick fix, I finally re-installed Mac OS X.

After a 40 minute installation, and 2 and a half hours of software updates, Halo is finally running. And a lot of other minor problems non-halo related are finally fixed too.

Thanks for everyone's help.