PDA

View Full Version : iMac G3 won't sleep




mrkramer
May 18, 2007, 12:39 AM
I have a 500mhz iMac G3. I just got it so it has a fresh install of 10.3.9, but when I try to put it to sleep the screen goes off, and then comes back on immedietly. Could someone please help.



mad jew
May 18, 2007, 12:41 AM
Any devices plugged in?

Eidorian
May 18, 2007, 12:42 AM
Have you tried it with a different mouse and keyboard?

mrkramer
May 18, 2007, 12:48 AM
I don't have anything other than the mouse, keyboard, and ethernet cable plugged in. unfortunatly I don't have another keyboard and mouse sitting around to try it with. I was thinking about it, and I did put in a peice of ram from an old PC in it, could that be the problem?

Eidorian
May 18, 2007, 12:50 AM
I don't have anything other than the mouse, keyboard, and ethernet cable plugged in. unfortunatly I don't have another keyboard and mouse sitting around to try it with. I was thinking about it, and I did put in a peice of ram from an old PC in it, could that be the problem?I doubt it's the RAM. I've had finicky input devices (or other USB devices for that matter) wake Macs from sleep before.

mrkramer
May 18, 2007, 12:51 AM
I doubt it's the RAM. I've had finicky input devices (or other USB devices for that matter) wake Macs from sleep before.

Ok I'll see if it does it still when it sleeps on a timer, without the keyboard and mouse plugged in.

mad jew
May 18, 2007, 12:52 AM
Also, in the Energy Saver pane of System Preferences, is Wake For Ethernet checked? This shouldn't but sometimes does wake a Mac unnecessarily. Maybe test it without the ethernet cable plugged in too. :)

Eidorian
May 18, 2007, 12:52 AM
Also, in the Energy Saver pane of System Preferences, is Wake For Ethernet checked? This shouldn't but sometimes does wake a Mac unnecessarily.I was going to mention wake-on-LAN but I had my doubts that someone would be trying to log into it or wake it.

Then again my G4's stay dead when I try to ssh in as admin. *grumbles*

mad jew
May 18, 2007, 12:54 AM
I think it's a bit buggy 'cause I've seen turning this option off sometimes let a Mac sleep properly. Maybe it's something to do with router transmissions... I dunno.

Eidorian
May 18, 2007, 12:55 AM
I think it's a bit buggy 'cause I've seen turning this option off sometimes let a Mac sleep properly. Maybe it's something to do with router transmissions... I dunno.Internet background radiation... :rolleyes:

mrkramer
May 18, 2007, 12:59 AM
I just tried it without the keyboard and mouse, and it slept fine, so I guess that was the problem, thanks for your help. Now I need to find out which one is causing it, and replace it.

montex
May 18, 2007, 01:29 AM
I hope you've replaced the PRAM battery recently. Those iMac G3s came out 7 years ago and the PRAM battery isn't designed to last longer than 5 years. You can get one at your local Radio Shack. I have updated many old iMacs and I find that a new PRAM battery fixes a lot of mysterious problems that defy explanation.