PDA

View Full Version : "Call Forwarding Active" popup message




pherplexed
Jul 2, 2007, 10:21 PM
Everytime i make a call, a little popup comes up that says "Call Forwarding Active" with a button that says dismiss. I can either hit the button or it just goes away after a few seconds.

Anybody else getting this or know what this means? I checked the settings and call forwarding isn't turned on....and i'm receiving calls as normal. Just curious why it says that everytime i make a call.



loudestnoise
Jul 2, 2007, 10:25 PM
Apparently you have call forwarding on. I used CallWave before getting iPhone and to disable call forwarding you type ##004# and hit call. May or may not work on iPhone.

pherplexed
Jul 2, 2007, 10:27 PM
Apparently you have call forwarding on. I used CallWave before getting iPhone and to disable call forwarding you type ##004# and hit call. May or may not work on iPhone.

there's no way i have call forwarding on because i'm receiving phone calls. and the call forwarding under settings is turned off.

unity
Jul 2, 2007, 11:27 PM
Try re-booting?

jt2ga65
Jul 3, 2007, 08:28 PM
AT&T has a feature called call forwarding that will forward your calls to voice mail if you are on the phone. I don't recall seeing the message until just a few months ago on my Razr, but I suspect that it works the same on the iPhone.

I've tested mine by dialing out, and then calling the phone while still on the initial call. I get the "outgoing call forwarding" message, but am still able to answer the second call, and all the other features also work. I don't know what would happen if I got a third call. I'm not sure what the limit is.

Perhaps you don't have wall waiting turned on?

-jt2

mkrishnan
Jul 3, 2007, 08:32 PM
AT&T has a feature called call forwarding that will forward your calls to voice mail if you are on the phone. I don't recall seeing the message until just a few months ago on my Razr, but I suspect that it works the same on the iPhone.

I get this inconsistently on T-Mobile GSM phones... I've always thought that it meant that network limitations would prevent me from using call waiting to answer the interrupting call, but in truth, I have never understood what it means. :confused:

Bradley W
Jul 3, 2007, 09:45 PM
_

applepro
Jul 3, 2007, 11:40 PM
having same problem :(

I not remember having it before

c.greene914
Jul 4, 2007, 10:38 AM
I would like to know something about this issue as well. Just an annoyance, but I would like it to go away.

mkrishnan
Jul 4, 2007, 11:00 AM
I did some searching, and it's widely reported, particularly on Nokias, but no one can seem to explain what it means or when it is triggered.... :( I can vouch that, having spent more than three years on a phone that does it, that it is harmless and doesn't appear to affect anything la charges or functionality. (Now that I think about it, I thought, but am not completely sure, that I've seen it on my RAZR, but all the forum complaints seem to be about Nokia.)

Bradley W
Jul 5, 2007, 04:22 PM
_

rayward
Jul 5, 2007, 05:20 PM
Turn Call Forwarding on and off under Settings > Phone > Call Forwarding.

It sends your incoming calls to another number that you specify. A cool feature if you ask me. It means, for example, that you can forward your calls to your home number when you leave your iPhone docked with your computer for a recharge.

Bradley W
Jul 6, 2007, 08:45 AM
_

megfilmworks
Jul 6, 2007, 08:57 AM
That's the strange thing about this problem - I (and likely the others with this issue) have Call Forwarding disabled... yet the message still comes up. I guess I'll just wait until the next software update.

I believe this message comes up when the party you are calling is on call forwarding. Its warning you that your call is being forwarded.

freeflydrew
Jul 6, 2007, 09:15 AM
i agree... as if the phone alerts you when you call a number and the phone call gets forwarded to their voicemail. At least thats exactly what just happened to me.

Andrmgic
Jul 6, 2007, 09:24 AM
Yeah, I think it means that your call is getting forwarded.. that would make the most sense.

Julian0714
Jul 6, 2007, 10:18 AM
Yeah, I think it means that your call is getting forwarded.. that would make the most sense.


I don't know if thats what it is, because when I call my home land-line, which is basic service, no forwarding possible or anything like that, I still get the call forwarding active popup. It happens whether call forwarding is turned on or off on the iPhone.

pherplexed
Jul 9, 2007, 02:55 PM
So i finaly just called AT&T to see what the deal was. According to them, it's a standard message for GSM networks indicating that the call you placed has successfully connected ("forwarded") to the person's phone you're calling.

Strange wording, but basically she said it's standard on a GSM network...some phones display it, others don't.

hbg
Jul 10, 2007, 07:27 PM
I have been on ATT's GSM network for over a year with multiple phones and the Blackjack prior to getting the iPhone and I have never gotten this message until the iPhone- I think that is nonsense that someone at ATT told you.

My call forwarding is turned off. Also, I get it when I call to numbers (e.g., my home) that do not have numbers call forwarded anywhere. In short, I do not believe those explanations are valid either. It sounds to me like a bug in the iPhone.

pherplexed
Jul 11, 2007, 07:33 AM
I have been on ATT's GSM network for over a year with multiple phones and the Blackjack prior to getting the iPhone and I have never gotten this message until the iPhone- I think that is nonsense that someone at ATT told you.

My call forwarding is turned off. Also, I get it when I call to numbers (e.g., my home) that do not have numbers call forwarded anywhere. In short, I do not believe those explanations are valid either. It sounds to me like a bug in the iPhone.

I think it's entirely possible that you know more than the AT&T engineers that i spoke with. So, you should call them and tell them how to fix this "bug" you found.

thatguy_youknow
Jul 12, 2007, 02:18 AM
My phones have been showing this message for years (at least 8 since I got a phone with PacBell pre Cingular pre AT&T). I notice it more in some areas more than other but don't notice a pattern.

ramatsu
Jul 16, 2007, 06:03 PM
I have had my iPhone for a week, and this just started for me about two days ago. I verified that it doesn't have anything to do with whether the person I'm calling has call forward on. None of the theories posed here so far account for what i'm seeing, so it will be nice if it gets enough attention that Apple can try to do something about it.

badtzmaru
Jul 16, 2007, 09:11 PM
OK so i just got off the phone with att because I had the exact same message pop up when i dial one particular person.

the att person was unable to help me but went so far as to offer to send me a new iphone!

so anyway i called the person who is on T-Mobile/GSM. He explained that he forwards his voice mail to a different number -- meaning the message only comes up when i cant reach him and end up in his voice mail system.

the same message pops on his phone (he has some sort of blackberry) but only for a brief second -- whereas the iphone implementation pops up a message box with the "dismiss" button

bottom line is that appears to be a GSM thing. but i am tempted to get me a replacement phone just for kicks :)

wsdr
Aug 6, 2007, 09:33 AM
Howdy, this "call forwarding active" message pops up on a lot of phones, not just the iPhone. I used to be on SunCom ("A Member of the AT&T Wireless Network") and started getting these messages on my Sony Ericsson, Nokia and Motorola phones once I started using GSM.

My theory is that there is a brief period of time while you are dialing out wherein the GSM system cannot deliver a new incoming call to you. Have you ever mysteriously gotten a voice mail less than a minute after having started a new call? I have. I think that while my phone is connecting to the number I have just dialed, the network simply forwards all new incoming calls straight to voicemail (or your forwarding destination should you have set one). A corollary is that I have been attempting to dial a new number, hit send, and just as the phone starts to connect, the outgoing call is dropped and a new call rings in. I think this is the same limitation-- one connection can be STARTED at a time; but once the connection is established, more can come in.

All that said, I find the pop-up EXTREMELY annoying. Often I have my phone on either a headset, handset or Bluetooth, and need to switch to one of the other options (say handset to speaker, or headset to bluetooth). Often I can't get to the dialog to make the switch quickly enough because of that darn message.

I would LOVE to find a way to disable that dialog.

Roy Hobbs
Aug 6, 2007, 09:40 AM
Everytime i make a call, a little popup comes up that says "Call Forwarding Active" with a button that says dismiss. I can either hit the button or it just goes away after a few seconds.

Anybody else getting this or know what this means? I checked the settings and call forwarding isn't turned on....and i'm receiving calls as normal. Just curious why it says that everytime i make a call.

Call at&t??

wsdr
Aug 6, 2007, 10:25 AM
Call at&t??

Ha! That's a good one. :p

rhennard
Aug 19, 2007, 02:23 PM
Ok,this message just started popping up and it has never happened before. Here is a clue ... I am on vacation. I am not in my usual area. In fact, i am in a pretty rural area . I rebooted, checked the settings etc. I am sure it is not the phone but an att problem . For those on this thead that keep calling for or insisting that its a phone setting prpblem please stop. My calls to att were a waste of time. Any new news please post. Thank you

gunitsold1er
Aug 19, 2007, 08:20 PM
when i was in mexico (international) i got "call fowarding dismissed" message that would pop up when i made a outgoing call.. but never got that message when i was in the us... idk just throwing it out there might be a :apple: thing

megfilmworks
Aug 19, 2007, 08:21 PM
You will get it in the US when the person you are calling has their number being forwarded. This is not a problem and has nothing to do with your settings. (Unless you are roaming) It is just a warning that your call to JoJos cell phone is being forwarded to his office.
Dismiss?

rhennard
Aug 20, 2007, 06:26 AM
You will get it in the US when the person you are calling has their number being forwarded. This is not a problem and has nothing to do with your settings. (Unless you are roaming) It is just a warning that your call to JoJos cell phone is being forwarded to his office.
Dismiss?

Wrong. In testing this I called my house which is and was not forwarded!!! I am back in my normal calling area now and all is well. I am telling you this is a bug in which att is involved. In my return home through two states it happened about 30% of the time and I was calling my home number everytime .

lonnielove
Aug 20, 2007, 12:44 PM
OK so i just got off the phone with att because I had the exact same message pop up when i dial one particular person.

the att person was unable to help me but went so far as to offer to send me a new iphone!

so anyway i called the person who is on T-Mobile/GSM. He explained that he forwards his voice mail to a different number -- meaning the message only comes up when i cant reach him and end up in his voice mail system.

the same message pops on his phone (he has some sort of blackberry) but only for a brief second -- whereas the iphone implementation pops up a message box with the "dismiss" button

bottom line is that appears to be a GSM thing. but i am tempted to get me a replacement phone just for kicks :)
DO IT!!!

jmdeegan
Aug 20, 2007, 01:09 PM
Doesn't matter if its the iPhone or not. I have a Razr via ATT, and have seen that message off an on at least for a few weeks, most often when I was recently on vacation in South Carolina.

It does not mean your calling party's number is forwarded. That much I know with 100% certainty. My best guess as a telecom engineer just means it's telling you, should another call come in to your phone, as others have said, your call forwarding is activated. IE, the 2nd call if you dont answer, goes to voicemail, which is an example of call forwarding. And that specific instance is always active by default.

My guess is someone missed an "on/off" checkbox in some settings as areas were getting updated, as I've never seen it otherwise prior to summer 2007, and have had GSM phones for pretty much as long as they've been out

zigziggityzoo
Aug 20, 2007, 02:31 PM
My guess? I bet it has to do with the tower you're connected to. The older towers do this.

Why only on certain phones? Same reason why some websites work on IE, and not on safari: Safari doesn't bend or break the rules.

I'm sure this message was once a useful feature, but now it's been reduced to a mere annoyance at best.

EDIT: for the record, I've seen this randomly occur on virtually every phone I've owned in the past six years.

dmweinst
Aug 23, 2007, 03:58 PM
I am currently on vacation in Lake Placid NY with 5 other people all with AT&T phones. We have been coming here for 5 years every summer and we have seen and continue on this trip to see this message on every one of our phones (Nokias, RAZRs and iPhone) on every outgoing call. The first time I saw it I called AT&T and was told it was normal and caused by the fact that the AT&T network was built by acquiring and/or partnering with a number of large and small cellular networks. I believe you will continue to see this message in areas that are contractually part of the AT&T network, but in which the technology has not yet been fully integrated and/or updated to the latest standards.

megfilmworks
Aug 23, 2007, 09:47 PM
In Southern California it pops up only when the party you are calling has his phone being forwarded. That can include voicemail. Seems that the posters with different issues in other parts of the country have carrier problems. It is not iPhone specific. I agree with dmweinst post above as well.

Thor-oh
Sep 15, 2007, 10:37 PM
This popup has just started happening to me since:
1) I got iPhone in June (prior AT&T customer)
2) only person I call and I get the message with has moved and changed number to new ATT number which I am calling (and has forwarding on from old att number to new att number)

I think it is the ATT network that is getting networks confused.

In this case, I have a Massachusetts number calling out of Virginia to a friend with a Texas number which is forwarding from a Maryland number.

Its a wonder the thing works at all.

whistler72
Sep 15, 2007, 10:46 PM
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420+ (KHTML, like Gecko) Version/3.0 Mobile/1C28 Safari/419.3)

I've wondered the same thing!

Kalinatek
Sep 17, 2007, 02:41 PM
its normal happens to some people using certain networks and doesn't show up on certain networks..

:cool:

ngdesign
Oct 17, 2007, 05:58 PM
i didn't have it until i set up the voicemail service.. now everytime i make a call, popup comes

i tried to switch on/off the forwarding at setting, popup is gone so is my voicemail service... weird

voicemail is a little more important than the pop up tho.

my girl doesn't have this problem, but when she gets a voicemail her phone will keep ringing from the provider until she picks up and listen the voicemail..lol

mrhip
Oct 19, 2007, 07:14 AM
I was getting the "call forwarding popup" and used ##004# it got rid of the popup but it deactivated my voice mail and every time I reactivate my voicemail dialing 1750 the popup apears again. So I have to choose between having my voicemail or the stupid popup everytime I make a call. Im using an american unlocked iphone with O2 UK. Can anyone help please.

ying yang
Nov 1, 2007, 03:08 PM
I'm using an unlocked iPhone in Ireland and I only get this popup when calling one number. Unfortunately the number is the O2 Topup line which I call a lot.

I haven't gotten this message when calling any other number.

helderluis
Nov 13, 2007, 09:31 AM
Found this in other forum:

How to hide "Call forwarding active" message...

This only works with 1.1.1 firmware

Well, some people get a "call forwarding active" message every time they do a call.

There is a simple way to hide this message:

Download the file on your iPhone called com.apple.carrier.plist found at /var/root/Library/Preferences/ and edit the key ShowCallForwarding to be <false/>. Reboot! There you go, you don't get that annoying message anymore :-)

There are two settings in com.apple.carrier.plist:

ShowCallForwarding: Message shown on outgoing calls, if your number is beeing forwarded.
ShowCallForwarded: Message shown on incoming calls, if caller has been forwarded to you.

myemaildw
Aug 10, 2008, 01:24 PM
I used CallWave before getting iPhone and to disable call forwarding you type ##004# and hit call. May or may not work on iPhone.

Worked perfectly on my iPhone 16GB. I no longer get the message.

Clewis
Aug 11, 2008, 05:31 PM
"ShowCallForwarding to be <false/>" - does this mean "null"?

netsped
Aug 11, 2008, 07:39 PM
If you have SSH installed you can do the following (it worked for me)

1.-Access via ssh to this route:

/ private / var / mobile / Library / Carrier Bundle.bundle / part in bold depends on your carrier, if the name you choose your carrier, if not the name of your carrier you choose the route above. In the case of movistar this is the path:

/ System / Library / Carrier Bundles / Telefonica_es.bundle

2 .- Download the file and edit carrier.plist converts with LINK (http://140.124.181.188/%7Ekhchung/cgi-bin/plutil.cgi).

Search:

<key> ShowCallForwarded </ key>
And be sure that puts
<false/>
After looking
<key> ShowCallForwarding </ key>
and again put
<false/>

Save and it is ready

PS. Translated from spanish with google.

PS2. From Link (http://www.planetaiphone.es/elimina-el-desvio-de-llamada-activado-en-20/)

uros1977
Oct 14, 2009, 05:44 AM
I've looked into it at my operator in Slovenia. I have an iphone 3GS, and I'm also getting the message "call fowarding active". And that although my call forwarding in my phone is set to off. This is because I have another future enabled. I don't know how your operators are warning you about your missed calls, but we get, like a message from the person who was trying to call us, but we were temporarily unavailable or there was no signal. And even though that future is enabled at my operator and not on my phone, we're stil getting this message. It's like a notification for this particular future. But it goes away in a matter of seconds so I don't really see the problem. I hope I've helped,

best regards

Peter444a
Oct 25, 2009, 04:15 AM
this website has an easy step by step "code dial" guide, which disables it .
worked for me :P
very easy and quick fix
http://kaputik.com/?p=847

buckels
Nov 24, 2009, 09:28 AM
hi
i used the ##002# code to try to (unsuccessfully) get rid of the call forwarding active pop up.

now my voicemail is unreachable.
how can i re-activate the forwarding.
I am using an australian Iphone on German o2 network (should be easy to solve).. they say it is active (it is, i can call and hear that i have no messages, surprise surprise, as none are getting forwarded)
does anyone know the code to reactivate all that I've lost thanks to the ##002# call..
and i'm very new, so use words your mum would understand..
cheers

Moi un Mouton
Nov 24, 2009, 11:56 AM
hi
i used the ##002# code to try to (unsuccessfully) get rid of the call forwarding active pop up.

now my voicemail is unreachable.
how can i re-activate the forwarding.
I am using an australian Iphone on German o2 network (should be easy to solve).. they say it is active (it is, i can call and hear that i have no messages, surprise surprise, as none are getting forwarded)
does anyone know the code to reactivate all that I've lost thanks to the ##002# call..
and i'm very new, so use words your mum would understand..
cheers

Well, on O2 UK it is 1750, so you could try dialling that.

alexasupertramp
Nov 30, 2009, 08:05 PM
Everytime i make a call, a little popup comes up that says "Call Forwarding Active" with a button that says dismiss. I can either hit the button or it just goes away after a few seconds.

Anybody else getting this or know what this means? I checked the settings and call forwarding isn't turned on....and i'm receiving calls as normal. Just curious why it says that everytime i make a call.


To rid yourself of this annoying popup: go to phone dialler (number pad), type in ##002# and press DIAL button. A screen will appear with a DISMISS button, press DISMISS and voila!! no more popup