PDA

View Full Version : Powerbook batteries taking NINE hour charge - HELP!!!




Porksword
Sep 3, 2007, 09:33 PM
I have two batteries and two powercords for my PB G4 17inch and all of a sudden both batteries say they will need 9+ hours charge. Tried both batts and both powercords. Reset the PMU by unplugging and holding power for 5 sec. Turn it back on, it says the time has been reset but still needs forever to charge.



MikeTheC
Sep 3, 2007, 10:13 PM
Well, if you're looking to troubleshoot this...

Find someone else with the same (or similar) model of PowerBook that you've got, and try charging the batteries in it. If it does the same thing, then it's your batteries. If not, it may be the charging circuitry in your PB.

Also, were your batteries a part of that recall that Apple had? If they were, you may be able to get them exchanged under warranty. If not, well...

Porksword
Sep 3, 2007, 10:18 PM
I didn't think any of the 17-inches were part of the recall. Am I wrong?

aphexacid
Sep 4, 2007, 12:06 AM
i dont think the 17" models were included. if they were, then hell, where do i sign up?

Porksword
Sep 4, 2007, 09:48 AM
Also, when charged, the batteries perform as usual.

Porksword
Sep 4, 2007, 10:11 AM
bump

Porksword
Sep 5, 2007, 08:40 AM
Now I've noticed that when I'm running system intense apps, my battery may take 12+ hours to charge.

majidf
Sep 5, 2007, 08:46 AM
Considered trying a friends powerbrick? Maybe yours not working properly.

Porksword
Sep 5, 2007, 08:50 AM
Unfortunately I don't know anyone else with a 17-inch. But still find it odd that both of mine do the same thing.

majidf
Sep 5, 2007, 10:47 AM
15 inch might do, I think they have same wattage, but you could verify if you know anyone with such powerbook.

Jiddick ExRex
Sep 5, 2007, 12:18 PM
All the old models run on the same wattage so knock yourself out...

Porksword
Sep 5, 2007, 12:54 PM
I've tried 4-5 different power cords all with the same result. I think I may have a bad logic board/PMU. I may have to bring it in. :mad: