PDA

View Full Version : Biiiiigg Problem!


Rumbach
Oct 30, 2003, 04:52 PM
Last night my twin G4 (867 MDD) lost power in a blackout, and now when I try to restart it, the power switch will glow when I depress the button, but fade as soon as I let off - no start up sound, no fan kicking in.

Is my logic board fried?

I thought maybe I should reset the PMU switch on the board, but wanted to know if I needed to take the battery out first.

Anyone else have this problem?

I tried leaving it unplugged overnight and retrying, but same results...

help, please?!

Counterfit
Oct 30, 2003, 05:12 PM
Try the button. Press it ONCE and do NOT hold it. And I don't think you need to take out the battery. Check the knowledge base just in case.

G4scott
Oct 30, 2003, 05:29 PM
If it still doesn't work, there's a 'hard reset' button somewhere on the mobo. That might work. I'm pretty sure someone around here has a pic of what this button looks like. It's small, and round, on a metal square thing...

Makosuke
Oct 30, 2003, 05:53 PM
There was an extensive discussion on this issue at MacInTouch right after the big East Coast US blackout.

The concensus, if memory servers, was that it's probably not permanantly broken. Resetting the motherboard is one option, or you could do the complete reset of removing the battery, unplugging the computer, then pressing the power button till it stops glowing, then putting the battery back in and pushing the motherboard reset button.

My memory on that procedure may be faulty, though (you might not have to remove the battery, and there might've been an additional power manager reset step at startup involving Open Firmware), so I'd recommend going to MacInTouch and reading through their archives.

Just unplugging the computer for a few hours might fix it, too.

FuzzyBallz
Oct 30, 2003, 08:06 PM
Or it could just be a busted PSU.

wr0x2
Oct 30, 2003, 08:18 PM
As a somewhat experianced overclocker (mostly PCs, only once on a Mac) I'm a firm believer in that unless it has smoke coming out of it :D a hard reset will work. Obviously this isn't always true, but most of the time it's just the trick.

Do the reset.

Rumbach
Oct 30, 2003, 11:58 PM
Fixed it!

It just required a PMU reset.

Took about 3 minutes, once I had
the proper schematics locating the switch.

thanks for the replies!

Andy