PDA

View Full Version : iBook g4 airport working, but no connection in firefox or safari




galstaph
Apr 25, 2008, 05:20 PM
Alright so here is the problem my iBook, (g4, 1.33ghz, 12" 10.4.11) connects no problem to my router via airport (confirmed via router log, ip is leased) BUT I am not able to get safari nor firefox to connect to the internet.
Any suggestions?



SkyBell
Apr 26, 2008, 01:21 PM
Is this a new problem? Have you been able to connect by Airport before? Maybe check your settings of how those browsers connect?
\

CanadaRAM
Apr 26, 2008, 02:08 PM
Connected but no Internet is usually a DNS problem,

What are your network settings for the Airport connection?
IP address
Router.Gateway address
Subnet mask
DNS address(es)

galstaph
Apr 26, 2008, 03:25 PM
new problem within the last week or so. Router and airport talk just fine (verified via router log files showing ibooks mac address leasing properly), hell I can even look at the ibook via airport from my mbp! I'm almost thinking of just doing a reinstall of tiger (or I can upgrade to 10.5), but I'm not sure it'll fix it.

I'll maybe try zapping the pram see if it helps - (edit) didn't help :(

tdhurst
Apr 26, 2008, 03:39 PM
What are your DNS settings on the laptop?

galstaph
Apr 26, 2008, 03:57 PM
left blank, but just tried the dns server from my mbp, 192.168.0.1 and the search domain (my isp) still nada

CanadaRAM
Apr 27, 2008, 05:37 AM
left blank, but just tried the dns server from my mbp, 192.168.0.1 and the search domain (my isp) still nada

192.168.0.1 is not the DNS server, it is the router's IP address

Try entering the OpenDNS server numbers 208.67.222.222 and 208.67.220.220

galstaph
Apr 28, 2008, 11:09 AM
CanadaRAM, that didn't work. Jut got it to though. I assigned a static ip and viola it works! (must be because we have so much on the network, 2 ps3's, wireless printer, and 2 lappys) thanks for your help guys:)