PDA

View Full Version : Error Verifying Application




bkphat
Jul 21, 2008, 02:40 PM
Hey,

If anyone can help me solve this, will donate 10 of my hard earned student dollars to charity.

I think I have tried literally everything to make this work. I can not seem to transfer the app to the device for testing. This is what I've done so far:

1. Requested a key in the key chain manager. Saved it to disk and uploaded it to the Dev Portal.
2. I got a certificate and installed it, as well as moved it to Library/MobileDevices/Provisions I also got the WWDR certificate and installed that.
3. I registered an app ID and added my iPhone ID to the list of Devices.
4. I made a provision profile, downloaded it, installed it and saved it into Library/MobileDevices/Provisions. I checked the iPhone itself to verify that it was installed.
5. I edited the build settings to display all the code signing identity stuff as instructed by the pdf in the dev portal.

When I try to build in either debug/release onto the device, it gives me a verification error:

"Your mobile device has encountered an unexpected error (0xE8000001) during the install phase: Verifying application"

I read the other thread on this issue, but nothing seems to help. Maybe someone else has experienced this.


thanks



ayasin
Jul 21, 2008, 04:10 PM
make sure you set the target settings not just the project settings. They look the same so it's easy to choose the wrong one.

bkphat
Jul 21, 2008, 04:37 PM
nope. nothing changed. same old error. it was set already. thanks though.

DaveGee
Jul 21, 2008, 07:30 PM
nope. nothing changed. same old error. it was set already. thanks though.

I had this exact same problem.... Here is how I got things to work... under profiles I created a 'wildcard' profile... You use an * instead of a project name... and then 'attached?' THAT profile to the project I was working on and bang it worked like a charm!

I hope this helps and if it does instead of making a donation just buy the next homeless person you see a nice sandwich and drink... :)

Dave