PDA

View Full Version : Apps crashing back to the home page?




firewood
Jul 23, 2008, 10:59 AM
Has any developer seen a problem where users report that an app crashes back to the home page a few seconds after launch, but the app seems to work just fine on all the developers test devices and on the Simulator?

Is this a problem with only certain types of apps (maybe those with potential memory/object dealocation issues)? Or with all apps?

Are some of these crash problems fixed by a reset, or complete OS restore?



pgk2008
Jul 23, 2008, 11:17 AM
Many people including myself have noticed that installing apps from the iPhone, and then using 'sync apps' from iTunes on the PC leads to apps that do not start (app window opens, and closes again after ~1 second brniging the user back to the home screen). The only solutions that I have seen are (a) to disable app syncing, and reinstall the affected apps again on the phone, or (b) to install the apps via iTunes. -pgk

tacoman667
Jul 23, 2008, 12:13 PM
I can't help but wonder if this isn't an issue with other apps that have run before using the "affected" application have poor memory management. This could cause the app to shut down as a way to attempt a cleanup of memory from the kernel.

I have had apps shut down to the home screen after a minut of use but after a reboot of the iPhone, all is well again. I will even reopen the same app and never have a crash.

Just my 2 cents.

admanimal
Jul 23, 2008, 02:15 PM
I can't help but wonder if this isn't an issue with other apps that have run before using the "affected" application have poor memory management. This could cause the app to shut down as a way to attempt a cleanup of memory from the kernel.



All of an app's memory is freed as soon as it quits (even leaked memory), so that shouldn't be the cause.

However you could be on the right track in that the OS could be sending erroneous low memory warnings.

SwampThingTom
Jul 24, 2008, 04:29 PM
I strongly believe this is a problem in the iPhone OS and not a problem with faulty apps. It seems to be happening with many apps and, as others have said, rebooting the phone always fixes the problem.

Tom